GFI HelpDesk < 4.99.9 Stored XSS via charset Parameter
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
GFI HelpDesk before 4.99.9 contains a stored cross-site scripting vulnerability in the language management functionality where the charset POST parameter is passed directly to SWIFT_Language::Create() without HTML sanitization and subsequently rendered unsanitized by View_Language.RenderGrid(). An authenticated administrator can inject arbitrary JavaScript through the charset field when creating or editing a language, and the payload executes in the browser of any administrator viewing the Languages page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GFI Software | HelpDesk | before 4.99.9 | 4.99.9 | Patch available | CNA |
- HelpDesk VendorGFI Software Affected before 4.99.9 Fixed in 4.99.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gfi:helpdesk:*:*:*:*:*:*:*:* | before 4.99.9 | Vulnerable | GFI Software |
- cpe:2.3:a:gfi:helpdesk:*:*:*:*:*:*:*:* Versions before 4.99.9 Vulnerable ·GFI Software
Remediation
- Fix · CNA HelpDesk (GFI Software) Fixed in 4.99.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
GFI Software HelpDesk — gfi.ai/products-and-solutions/email-and-messaging-solutions…
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2026-19131 GFI HelpDesk < 4.99.9 Stored XSS via editsubject ParameterPriority LOW 27
- TI-2026-19130 GFI HelpDesk < 4.99.10 Stored XSS via Reports ModulePriority LOW 22
- TI-2026-19129 GFI HelpDesk < 4.99.9 Stored XSS via Troubleshooter Step SubjectPriority LOW 22
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23753
- 2026-10-03 Alias added: GHSA-xj4v-3q69-qpxx
References
More GFI Software Helpdesk vulnerabilities
- TI-2026-19131 GFI HelpDesk < 4.99.9 Stored XSS via editsubject Parameter CVSS 4.0MEDIUM 6.4
- TI-2026-19130 GFI HelpDesk < 4.99.10 Stored XSS via Reports Module CVSS 4.0MEDIUM 5.1
- TI-2026-19129 GFI HelpDesk < 4.99.9 Stored XSS via Troubleshooter Step Subject CVSS 4.0MEDIUM 5.1
- TI-2026-19125 GFI HelpDesk < 4.99.9 Stored XSS via companyname Parameter CVSS 4.0MEDIUM 4.8
Sources
- CVE-2026-23753 · CVE Program
- CVE-2026-23753 · NVD
- FIRST EPSS
- GHSA-xj4v-3q69-qpxx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences