Apollo Server is vulnerable to denial of service with `startStandaloneServer`
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-1333.
Summary
Apollo Server is an open-source, spec-compliant GraphQL server that's compatible with any GraphQL client, including Apollo Client. In versions from 2.0.0 to 3.13.0, 4.2.0 to before 4.13.0, and 5.0.0 to before 5.4.0, the default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to denial of service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as-integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| apollographql | apollo-server | 2.0.0 – 3.13.0; 4.2.0 to before 4.13.0; 5.0.0 to before 5.4.0 | 4.13.0, 5.4.0 | Patch available | CNA |
| — | apollo-server (npm) | 2.0.0 – 3.13.0 | — | No fix listed | GHSA-mp6q-xf9x-fwf7 |
| — | @apollo/server (npm) | 4.2.0 to before 4.13.0 | 4.13.0 | Patch available | GHSA-mp6q-xf9x-fwf7 |
| — | @apollo/server (npm) | 5.0.0 to before 5.4.0 | 5.4.0 | Patch available | GHSA-mp6q-xf9x-fwf7 |
- apollo-server Vendorapollographql Affected 2.0.0 – 3.13.0; 4.2.0 to before 4.13.0; 5.0.0 to before 5.4.0 Fixed in 4.13.0, 5.4.0 Patch available CNA
- apollo-server (npm) Vendor— Affected 2.0.0 – 3.13.0 Fixed in — No fix listed GHSA-mp6q-xf9x-fwf7
- @apollo/server (npm) Vendor— Affected 4.2.0 to before 4.13.0 Fixed in 4.13.0 Patch available GHSA-mp6q-xf9x-fwf7
- @apollo/server (npm) Vendor— Affected 5.0.0 to before 5.4.0 Fixed in 5.4.0 Patch available GHSA-mp6q-xf9x-fwf7
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apollographql:apollo_server:*:*:*:*:*:*:*:* | 2.0.0 – 3.13.0; 4.2.0 to before 4.13.0; 5.0.0 to before 5.4.0 | Vulnerable | apollographql |
- cpe:2.3:a:apollographql:apollo_server:*:*:*:*:*:*:*:* Versions 2.0.0 – 3.13.0; 4.2.0 to before 4.13.0; 5.0.0 to before 5.4.0 Vulnerable ·apollographql
Remediation
- Fix · CNA apollo-server (apollographql) Fixed in 4.13.0, 5.4.0
- Fix · GHSA-mp6q-xf9x-fwf7 @apollo/server (npm) Fixed in 4.13.0 Advisory →
- Fix · GHSA-mp6q-xf9x-fwf7 @apollo/server (npm) Fixed in 5.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23897
- 2026-10-03 Alias added: GHSA-mp6q-xf9x-fwf7
References
Patch 2
Advisory 2
Sources
- CVE-2026-23897 · CVE Program
- CVE-2026-23897 · NVD
- FIRST EPSS
- GHSA-mp6q-xf9x-fwf7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences