Apache DolphinScheduler: Users are able to use tenants that are not defined on the platform during workflow execution.
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Incorrect Authorization vulnerability in Apache DolphinScheduler allows authenticated users with system login permissions to use tenants that are not defined on the platform during workflow execution. This issue affects Apache DolphinScheduler versions prior to 3.4.1. Users are recommended to upgrade to version 3.4.1, which fixes this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache DolphinScheduler | before 3.4.1 | 3.4.1 | Patch available | CNA |
| — | org.apache.dolphinscheduler:dolphinscheduler (Maven) | before 3.4.1 | 3.4.1 | Patch available | GHSA-72mv-wwvm-vgp5 |
- Apache DolphinScheduler VendorApache Affected before 3.4.1 Fixed in 3.4.1 Patch available CNA
- org.apache.dolphinscheduler:dolphinscheduler (Maven) Vendor— Affected before 3.4.1 Fixed in 3.4.1 Patch available GHSA-72mv-wwvm-vgp5
Remediation
- Fix · CNA Apache DolphinScheduler (Apache Software Foundation) Fixed in 3.4.1
- Fix · GHSA-72mv-wwvm-vgp5 org.apache.dolphinscheduler:dolphinscheduler (Maven) Fixed in 3.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23902
- 2026-10-03 Alias added: GHSA-72mv-wwvm-vgp5
References
More Apache Dolphinscheduler vulnerabilities
- TI-2022-22673 Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin CVSS 3.1CRITICAL 9.8
- TI-2022-22425 Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-28858 Apache DolphinScheduler: Remote Code Execution Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-26774 Remote Code Execution in Apache Dolphinscheduler CVSS 3.1CRITICAL 9.8
- TI-2020-09634 Deserialization of untrusted data in Apache DolphinScheduler CVSS 3.1CRITICAL 9.8
- TI-2024-28837 Incorrect default permissions in Apache DolphinScheduler CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-23902 · CVE Program
- CVE-2026-23902 · NVD
- FIRST EPSS
- GHSA-72mv-wwvm-vgp5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences