jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-1333.
Summary
jsdiff is a JavaScript text differencing implementation. Prior to versions 8.0.3, 5.2.2, 4.0.4, and 3.5.1, attempting to parse a patch whose filename headers contain the line break characters `\r`, `\u2028`, or `\u2029` can cause the `parsePatch` method to enter an infinite loop. It then consumes memory without limit until the process crashes due to running out of memory. Applications are therefore likely to be vulnerable to a denial-of-service attack if they call `parsePatch` with a user-provided patch as input. A large payload is not needed to trigger the vulnerability, so size limits on user input do not provide any protection. Furthermore, some applications may be vulnerable even when calling `parsePatch` on a patch generated by the application itself if the user is nonetheless able to control the filename headers (e.g. by directly providing the filenames of the files to be diffed). The `applyPatch` method is similarly affected if (and only if) called with a string representation of a patch as an argument, since under the hood it parses that string using `parsePatch`. Other methods of the library are unaffected. Finally, a second and lesser interdependent bug - a ReDOS - also exhibits when those same line break characters are present in a patch's *patch* header (also known as its "leading garbage"). A maliciously-crafted patch header of length *n* can take `parsePatch` O(*n*³) time to parse. Versions 8.0.3, 5.2.2, 4.0.4, and 3.5.1 contain a fix. As a workaround, do not attempt to parse patches that contain any of these characters: `\r`, `\u2028`, or `\u2029`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| kpdecker | jsdiff | 6.0.0 to before 8.0.3; 5.0.0 to before 5.2.2; 4.0.0 to before 4.0.4; before 3.5.1 | 8.0.3, 5.2.2, 4.0.4, 3.5.1 | Patch available | CNA |
| — | diff (npm) | 6.0.0 to before 8.0.3 | 8.0.3 | Patch available | GHSA-73rr-hh4g-fpgx |
| — | diff (npm) | 5.0.0 to before 5.2.2 | 5.2.2 | Patch available | GHSA-73rr-hh4g-fpgx |
| — | diff (npm) | 4.0.0 to before 4.0.4 | 4.0.4 | Patch available | GHSA-73rr-hh4g-fpgx |
| — | diff (npm) | before 3.5.1 | 3.5.1 | Patch available | GHSA-73rr-hh4g-fpgx |
- jsdiff Vendorkpdecker Affected 6.0.0 to before 8.0.3; 5.0.0 to before 5.2.2; 4.0.0 to before 4.0.4; before 3.5.1 Fixed in 8.0.3, 5.2.2, 4.0.4, 3.5.1 Patch available CNA
- diff (npm) Vendor— Affected 6.0.0 to before 8.0.3 Fixed in 8.0.3 Patch available GHSA-73rr-hh4g-fpgx
- diff (npm) Vendor— Affected 5.0.0 to before 5.2.2 Fixed in 5.2.2 Patch available GHSA-73rr-hh4g-fpgx
- diff (npm) Vendor— Affected 4.0.0 to before 4.0.4 Fixed in 4.0.4 Patch available GHSA-73rr-hh4g-fpgx
- diff (npm) Vendor— Affected before 3.5.1 Fixed in 3.5.1 Patch available GHSA-73rr-hh4g-fpgx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kpdecker:jsdiff:*:*:*:*:*:node.js:*:* | before 3.5.1; 4.0.0 to before 4.0.4; 5.0.0 to before 5.2.2; 6.0.0 to before 8.0.3 | Vulnerable | kpdecker |
- cpe:2.3:a:kpdecker:jsdiff:*:*:*:*:*:node.js:*:* Versions before 3.5.1; 4.0.0 to before 4.0.4; 5.0.0 to before 5.2.2; 6.0.0 to before 8.0.3 Vulnerable ·kpdecker
Remediation
- Fix · CNA jsdiff (kpdecker) Fixed in 8.0.3, 5.2.2, 4.0.4, 3.5.1
- Fix · GHSA-73rr-hh4g-fpgx diff (npm) Fixed in 8.0.3 Advisory →
- Fix · GHSA-73rr-hh4g-fpgx diff (npm) Fixed in 5.2.2 Advisory →
- Fix · GHSA-73rr-hh4g-fpgx diff (npm) Fixed in 4.0.4 Advisory →
- Fix · GHSA-73rr-hh4g-fpgx diff (npm) Fixed in 3.5.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 6 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-24001
- 2026-10-03 Alias added: GHSA-73rr-hh4g-fpgx
References
Patch 2
Advisory 2
Sources
- CVE-2026-24001 · CVE Program
- CVE-2026-24001 · NVD
- FIRST EPSS
- GHSA-73rr-hh4g-fpgx · GitHub Advisory Database · CC BY 4.0
- CVE-2026-24001 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences