Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| docling-project | docling-core | 2.21.0 to before 2.48.4 | 2.48.4 | Patch available | CNA |
| — | docling-core (PyPI) | 2.21.0 to before 2.48.4 | 2.48.4 | Patch available | GHSA-vqxf-v2gg-x3hc |
- docling-core Vendordocling-project Affected 2.21.0 to before 2.48.4 Fixed in 2.48.4 Patch available CNA
- docling-core (PyPI) Vendor— Affected 2.21.0 to before 2.48.4 Fixed in 2.48.4 Patch available GHSA-vqxf-v2gg-x3hc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:docling:docling-core:*:*:*:*:*:python:*:* | 2.21.0 to before 2.48.4 | Vulnerable | docling-project |
- cpe:2.3:a:docling:docling-core:*:*:*:*:*:python:*:* Versions 2.21.0 to before 2.48.4 Vulnerable ·docling-project
Remediation
- Fix · CNA docling-core (docling-project) Fixed in 2.48.4
- Fix · GHSA-vqxf-v2gg-x3hc docling-core (PyPI) Fixed in 2.48.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-24009
- 2026-10-03 Alias added: GHSA-vqxf-v2gg-x3hc
References
Patch 2
Advisory 2
More docling-project Docling-core vulnerabilities
- TI-2026-32063 Docling Core has unsafe remote filename resolution CVSS 3.1HIGH 8.6
Sources
- CVE-2026-24009 · CVE Program
- CVE-2026-24009 · NVD
- FIRST EPSS
- GHSA-vqxf-v2gg-x3hc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences