Local Privilege Escalation via Dynamic Library Injection in Waves Central for macOS
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-426.
Summary
Waves Central for macOS versions 13.0.9 through 16.5.5 contain a local privilege escalation vulnerability. A trusted XPC client component included with the product is signed with hardened runtime entitlements that permit dynamic library injection. A local attacker can set the DYLD_INSERT_LIBRARIES environment variable to inject an attacker-controlled dynamic library into the trusted client process at launch. The injected code runs within the signed process and can connect to the product's privileged helper service to invoke privileged operations, resulting in arbitrary code execution as root. The issue is fixed in version 16.6.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Waves Audio Ltd. | Waves Central | 13.0.9 – 16.5.5 | — | No fix listed | CNA |
- Waves Central VendorWaves Audio Ltd. Affected 13.0.9 – 16.5.5 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-24064
- 2026-10-03 Alias added: GHSA-6fpq-hqx5-5mq2
References
Advisory 1
More Waves Audio Ltd. vulnerabilities
- TI-2026-19392 Local Privilege Escalation via Insecure XPC Client Validation in Waves Central for macOS CVSS 3.1HIGH 8.1
- TI-2026-59363 Waves Central local privilege escalation via Improper XPC Client Authentication in macOS CVSS 4.0HIGH 8.4
Sources
- CVE-2026-24064 · CVE Program
- CVE-2026-24064 · NVD
- FIRST EPSS
- GHSA-6fpq-hqx5-5mq2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences