Stored XSS in PluXml CMS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
PluXml CMS is vulnerable to Stored XSS in Static Pages editing functionality. Attacker with editing privileges can inject arbitrary HTML and JS into website, which will be rendered/executed when visiting edited page. The vendor was notified early about this vulnerability, but didn't respond with the details of vulnerability or vulnerable version range. Only versions 5.8.21 and 5.9.0-rc7 were tested and confirmed as vulnerable, other versions were not tested and might also be vulnerable.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PluXml | PluXml CMS | 5.9.0-rc7; 5.8.21 | — | No fix listed | CNA |
- PluXml CMS VendorPluXml Affected 5.9.0-rc7; 5.8.21 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-24351
- 2026-10-03 Alias added: GHSA-jwfw-xx6c-8gwv
References
Other 1
More Pluxml vulnerabilities
- TI-2024-15087 PluXml Blog v5.8.9 was discovered to contain a remote code execution (RCE) vulnerability… CVSS 3.1HIGH 8.8
- TI-2025-41212 Authenticated Remote Code Execution (RCE) in PluXml CMS 5.8.22 allows an attacker with… CVSS 3.1MEDIUM 6.5
- TI-2025-43040 If the anti spam-captcha functionality in PluXml versions 5.8.22 and earlier is enabled… CVSS 3.1MEDIUM 5.3
- TI-2025-43039 A Stored Cross-Site Scripting (XSS) vulnerability exists in the PluXml article comments… CVSS 3.1MEDIUM 6.1
- TI-2020-13342 class.plx.admin.php in PluXml 5.7 allows attackers to execute arbitrary PHP code by… CVSS 3.1CRITICAL 9.8
- TI-2012-01986 Directory traversal vulnerability in update/index.php in PluXml before 5.1.6 allows… CVSS 2.0HIGH 7.5
Sources
- CVE-2026-24351 · CVE Program
- CVE-2026-24351 · NVD
- FIRST EPSS
- GHSA-jwfw-xx6c-8gwv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences