AutoGPT is Vulnerable to RCE via Disabled Block Execution
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863 and CWE-94.
Summary
AutoGPT is a platform that allows users to create, deploy, and manage continuous artificial intelligence agents that automate complex workflows. Prior to autogpt-platform-beta-v0.6.44, AutoGPT Platform's block execution endpoints (both main web API and external API) allow executing blocks by UUID without checking the `disabled` flag. Any authenticated user can execute the disabled `BlockInstallationBlock`, which writes arbitrary Python code to the server filesystem and executes it via `__import__()`, achieving Remote Code Execution. In default self-hosted deployments where Supabase signup is enabled, an attacker can self-register; if signup is disabled (e.g., hosted), the attacker needs an existing account. autogpt-platform-beta-v0.6.44 contains a fix.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Significant-Gravitas | AutoGPT | 0.1.0 to before 0.6.44 | 0.6.44 | Patch available | CNA |
| — | agpt (PyPI) | up to 0.2.2 | — | No fix listed | GHSA-r277-3xc5-c79v |
- AutoGPT VendorSignificant-Gravitas Affected 0.1.0 to before 0.6.44 Fixed in 0.6.44 Patch available CNA
- agpt (PyPI) Vendor— Affected up to 0.2.2 Fixed in — No fix listed GHSA-r277-3xc5-c79v
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:agpt:autogpt_platform:*:*:*:*:*:*:*:* | 0.1.0 to before 0.6.44 | Vulnerable | Significant-Gravitas |
- cpe:2.3:a:agpt:autogpt_platform:*:*:*:*:*:*:*:* Versions 0.1.0 to before 0.6.44 Vulnerable ·Significant-Gravitas
Remediation
- Fix · CNA AutoGPT (Significant-Gravitas) Fixed in 0.6.44
Timeline
- 2026-10-02 Threatist record created from CVE-2026-24780
- 2026-10-03 Alias added: GHSA-r277-3xc5-c79v
References
Other 6
- https://github.com/Significant-Gravitas/AutoGPT/blob/master/autogpt_platform/backend/backend/api/external/v1/routes.py#L79-L93
- https://github.com/Significant-Gravitas/AutoGPT/blob/master/autogpt_platform/backend/backend/api/features/v1.py#L1408-L1424
- https://github.com/Significant-Gravitas/AutoGPT/blob/master/autogpt_platform/backend/backend/api/features/v1.py#L355-L395
- https://github.com/Significant-Gravitas/AutoGPT/blob/master/autogpt_platform/backend/backend/blocks/block.py#L15-L78
- https://github.com/Significant-Gravitas/AutoGPT/blob/master/autogpt_platform/backend/backend/data/block.py#L459
- https://github.com/Significant-Gravitas/AutoGPT
More Significant-Gravitas Autogpt Platform vulnerabilities
- TI-2025-23471 AutoGPT has a DoS vulnerability in ReadRSSFeedBlock CVSS 4.0HIGH 8.7
- TI-2025-22672 AutoGPT allows leakage of cross-domain cookies and protected headers in requests redirect CVSS 3.1HIGH 8.6
- TI-2025-16489 AutoGPT SSRF vulnerability CVSS 4.0HIGH 7.7
- TI-2025-00879 Server-Side Template Injection (SSTI) in significant-gravitas/autogpt CVSS 3.1HIGH 8.8
- TI-2025-22671 AutoGPT allows SSRF due to DNS Rebinding in requests wrapper CVSS 3.1HIGH 7.5
- TI-2025-00371 SSRF Check Bypass in Requests Utility in significant-gravitas/autogpt CVSS 3.1HIGH 7.5
Sources
- CVE-2026-24780 · CVE Program
- CVE-2026-24780 · NVD
- FIRST EPSS
- GHSA-r277-3xc5-c79v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences