In Bun before 1.3.5, the default trusted dependencies list (aka trust allow list) can be…
Priority MEDIUM 60CWE-348Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In Bun before 1.3.5, the default trusted dependencies list (aka trust allow list) can be spoofed by a non-npm package in the case of a matching name (for file, link, git, or github).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00121 1st percentileScored 2026-11-07
Fix Fixed Bun (Bun): 1.3.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Bun (Bun) Fixed in 1.3.5
Timeline
- 2026-10-02 Threatist record created from CVE-2026-24910
- 2026-10-03 Alias added: GHSA-xp39-vp6q-phvj
References
Sources
- CVE-2026-24910 · CVE Program
- CVE-2026-24910 · NVD
- FIRST EPSS
- GHSA-xp39-vp6q-phvj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences