Read the docs
TI-2026-20315 Aliases CVE-2026-25153GHSA-6jr7-99pf-8vgf

@backstage/plugin-techdocs-node vulnerable to arbitrary code execution via MkDocs hooks

Priority LOW 39CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 fixed, 1 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-94.

Summary

Backstage is an open framework for building developer portals, and @backstage/plugin-techdocs-node provides common node.js functionalities for TechDocs. In versions of @backstage/plugin-techdocs-node prior to 1.13.11 and 1.14.1, when TechDocs is configured with `runIn: local`, a malicious actor who can submit or modify a repository's `mkdocs.yml` file can execute arbitrary Python code on the TechDocs build server via MkDocs hooks configuration. @backstage/plugin-techdocs-node versions 1.13.11 and 1.14.1 contain a fix. The fix introduces an allowlist of supported MkDocs configuration keys. Unsupported configuration keys (including `hooks`) are now removed from `mkdocs.yml` before running the generator, with a warning logged to indicate which keys were removed. Users of `@techdocs/cli` should also upgrade to the latest version, which includes the fixed `@backstage/plugin-techdocs-node` dependency. Some workarounds are available. Configure TechDocs with `runIn: docker` instead of `runIn: local` to provide container isolation, though it does not fully mitigate the risk. Limit who can modify `mkdocs.yml` files in repositories that TechDocs processes; only allow trusted contributors. Implement PR review requirements for changes to `mkdocs.yml` files to detect malicious `hooks` configurations before they are merged. Use MkDocs < 1.4.0 (e.g., 1.3.1) which does not support hooks. Note: This may limit access to newer MkDocs features. Building documentation in CI/CD pipelines using `@techdocs/cli` does not mitigate this vulnerability, as the CLI uses the same vulnerable `@backstage/plugin-techdocs-node` package.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00606 49th percentileScored 2026-11-07
Fix Partial backstage (backstage): 1.13.11@backstage/plugin-techdocs-node (npm): 1.14.1, 1.13.11Red Hat: 2 advisoriesRed Hat: 2 fixed, 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
backstagebackstagebefore 1.13.11; = 1.14.01.13.11Patch availableCNA
—@backstage/plugin-techdocs-node (npm)1.14.0 to before 1.14.11.14.1Patch availableGHSA-6jr7-99pf-8vgf
—@backstage/plugin-techdocs-node (npm)before 1.13.111.13.11Patch availableGHSA-6jr7-99pf-8vgf
  • backstage Vendorbackstage Affected before 1.13.11; = 1.14.0 Fixed in 1.13.11 Patch available CNA
  • @backstage/plugin-techdocs-node (npm) Vendor— Affected 1.14.0 to before 1.14.1 Fixed in 1.14.1 Patch available GHSA-6jr7-99pf-8vgf
  • @backstage/plugin-techdocs-node (npm) Vendor— Affected before 1.13.11 Fixed in 1.13.11 Patch available GHSA-6jr7-99pf-8vgf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:linuxfoundation:backstage:*:*:*:*:*:*:*:*before 1.13.11; 1.14.0 to before 1.14.1Vulnerablebackstage
  • cpe:2.3:a:linuxfoundation:backstage:*:*:*:*:*:*:*:* Versions before 1.13.11; 1.14.0 to before 1.14.1 Vulnerable ·backstage

Remediation

  • Fix · CNA backstage (backstage) Fixed in 1.13.11
  • Fix · GHSA-6jr7-99pf-8vgf @backstage/plugin-techdocs-node (npm) Fixed in 1.14.1 Advisory →
  • Fix · GHSA-6jr7-99pf-8vgf @backstage/plugin-techdocs-node (npm) Fixed in 1.13.11 Advisory →

Red Hat 2 advisories

  • RHSA-2026:6802 Released 2026-04-07 · Red Hat rating Important
    Red Hat Developer Hub 1.9.3 release.
    • Red Hat Developer Hub 1.9 registry.redhat.io/rhdh/rhdh-hub-rhel9, registry.redhat.io/rhdh/rhdh-rhel9-operator
  • RHSA-2026:6174 Released 2026-03-30 · Red Hat rating Important
    Red Hat Developer Hub 1.8.5 release.
    • Red Hat Developer Hub 1.8 registry.redhat.io/rhdh/rhdh-hub-rhel9, registry.redhat.io/rhdh/rhdh-rhel9-operator

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Self-service automation portal 2AffectedNo fix yet
Red Hat Developer Hub 1.8Fixed RHSA-2026:6174
Red Hat Developer Hub 1.9Fixed RHSA-2026:6802
Not affected: 2 products
  • Red Hat Developer Hub 1.8
  • Red Hat Developer Hub 1.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-25153
  2. 2026-10-03 Alias added: GHSA-6jr7-99pf-8vgf

References

  • TI-2023-17988 Insecure sandbox in Backstage Scaffolder plugin CVSS 3.1CRITICAL 9.9
  • TI-2026-69075 Sensitive information exposure in Backstage Scaffolder CVSS 3.1CRITICAL 9.6
  • TI-2026-69061 Path traversal in Backstage Bitbucket pull-request scaffolder actions CVSS 3.1CRITICAL 9.9
  • TI-2026-60083 Backstage: Improper input validation in TechDocs MkDocs configuration CVSS 3.1HIGH 8.8
  • TI-2026-69165 Backstage TechDocs config flaw allows code execution CVSS 3.1HIGH 8.8
  • TI-2026-69083 Code injection via MkDocs theme configuration in Backstage TechDocs CVSS 3.1HIGH 8.8
See all 52 →

Sources