Code injection in ACPT - Custom Post Types Plugin for WordPress
Priority MEDIUM 50CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-94.
Summary
Unauthenticated Remote Code Execution (RCE) in ACPT (Pro) - Custom Post Types Plugin for WordPress <= 2.0.47 versions.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00652 51st percentileScored 2026-11-07
Fix Fixed ACPT (Pro) - Custom Post Types Plugin for WordPress (ACPT): 2.0.52
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA ACPT (Pro) - Custom Post Types Plugin for WordPress (ACPT) Fixed in 2.0.52
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25470
- 2026-10-03 Alias added: GHSA-3xc6-wgx8-2ffv
More ACPT vulnerabilities
- TI-2026-25090 WordPress ACPT (Pro) - Custom Post Types Plugin for WordPress plugin <= 2.0.63 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-25093 WordPress ACPT (Pro) - Custom Post Types Plugin for WordPress plugin <= 2.0.63 - Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-25091 WordPress ACPT (Pro) - Custom Post Types Plugin for WordPress plugin <= 2.0.63 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
Sources
- CVE-2026-25470 · CVE Program
- CVE-2026-25470 · NVD
- FIRST EPSS
- GHSA-3xc6-wgx8-2ffv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences