SCEditor affected by DOM XSS via emoticon URL/HTML injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
SCEditor is a lightweight WYSIWYG BBCode and XHTML editor. Prior to 3.2.1, if an attacker has the ability control configuration options passed to sceditor.create(), like emoticons, charset, etc. then it's possible for them to trigger an XSS attack due to lack of sanitisation of configuration options. This vulnerability is fixed in 3.2.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| samclarke | SCEditor | before 3.2.1 | 3.2.1 | Patch available | CNA |
| — | sceditor (npm) | before 3.2.1 | 3.2.1 | Patch available | GHSA-25fq-6qgg-qpj8 |
- SCEditor Vendorsamclarke Affected before 3.2.1 Fixed in 3.2.1 Patch available CNA
- sceditor (npm) Vendor— Affected before 3.2.1 Fixed in 3.2.1 Patch available GHSA-25fq-6qgg-qpj8
Remediation
- Fix · CNA SCEditor (samclarke) Fixed in 3.2.1
- Fix · GHSA-25fq-6qgg-qpj8 sceditor (npm) Fixed in 3.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25581
- 2026-10-03 Alias added: GHSA-25fq-6qgg-qpj8
References
More Sceditor vulnerabilities
- TI-2019-14027 SCEditor 2.1.3 allows XSS. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-25581 · CVE Program
- CVE-2026-25581 · NVD
- FIRST EPSS
- GHSA-25fq-6qgg-qpj8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences