Apache NiFi: Missing Authorization of Restricted Permissions for Component Updates
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Apache NiFi 1.1.0 through 2.7.2 are missing authorization when updating configuration properties on extension components that have specific Required Permissions based on the Restricted annotation. The Restricted annotation indicates additional privileges required to add the annotated component to the flow configuration, but framework authorization did not check restricted status when updating a component previously added. The missing authorization requires a more privileged user to add a restricted component to the flow configuration, but permits a less privileged user to make property configuration changes. Apache NiFi installations that do not implement different levels of authorization for Restricted components are not subject to this vulnerability because the framework enforces write permissions as the security boundary. Upgrading to Apache NiFi 2.8.0 is the recommended mitigation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache NiFi | 1.1.0 to before 2.8.0 | 2.8.0 | Patch available | CNA |
| — | org.apache.nifi:nifi-web-api (Maven) | 1.1.0 to before 2.8.0 | 2.8.0 | Patch available | GHSA-c5w7-m8wf-xc77 |
- Apache NiFi VendorApache Affected 1.1.0 to before 2.8.0 Fixed in 2.8.0 Patch available CNA
- org.apache.nifi:nifi-web-api (Maven) Vendor— Affected 1.1.0 to before 2.8.0 Fixed in 2.8.0 Patch available GHSA-c5w7-m8wf-xc77
Remediation
- Fix · CNA Apache NiFi (Apache Software Foundation) Fixed in 2.8.0
- Fix · GHSA-c5w7-m8wf-xc77 org.apache.nifi:nifi-web-api (Maven) Fixed in 2.8.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25903
- 2026-10-03 Alias added: GHSA-c5w7-m8wf-xc77
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
Advisory 3
More Apache Nifi vulnerabilities
- TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
- TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
Sources
- CVE-2026-25903 · CVE Program
- CVE-2026-25903 · NVD
- FIRST EPSS
- GHSA-c5w7-m8wf-xc77 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences