Kanboard is Missing Access Control on Plugin Installation leading to Administrative RCE
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
Kanboard is project management software focused on Kanban methodology. Prior to 1.2.50, a security control bypass vulnerability in Kanboard allows an authenticated administrator to achieve full Remote Code Execution (RCE). Although the application correctly hides the plugin installation interface when the PLUGIN_INSTALLER configuration is set to false, the underlying backend endpoint fails to verify this security setting. An attacker can exploit this oversight to force the server to download and install a malicious plugin, leading to arbitrary code execution. This vulnerability is fixed in 1.2.50.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA kanboard (kanboard) Fixed in 1.2.50
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25924
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More Kanboard vulnerabilities
- TI-2026-17582 Kanboard is Vulnerable to Reverse Proxy Authentication Bypass CVSS 3.1CRITICAL 9.1
- TI-2025-34713 Kanboard Authenticated Admin Remote Code Execution via Unsafe Deserialization of Events CVSS 3.1CRITICAL 9.1
- TI-2024-34653 Remote code execution through language setting in kanboard CVSS 3.1CRITICAL 9.1
- TI-2024-34652 Arbitrary File Read and Delete in kanboard CVSS 3.1CRITICAL 9.1
- TI-2025-32655 Kanboard Password Reset Poisoning via Host Header Injection CVSS 3.1HIGH 8.8
- TI-2023-18607 Kanboard Authenticated SQL Injections vulnerability CVSS 3.1HIGH 8.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences