FUXA Unauthenticated Remote Code Execution in Node-RED Integration
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-290.
Summary
FUXA is a web-based Process Visualization (SCADA/HMI/Dashboard) software. From 1.2.8 through 1.2.10, an authentication bypass vulnerability in FUXA allows an unauthenticated, remote attacker to execute arbitrary code on the server when the Node-RED plugin is enabled. This has been patched in FUXA version 1.2.11.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| frangoteam | FUXA | 1.2.8 to before 1.2.11 | 1.2.11 | Patch available | CNA |
| — | fuxa-server (npm) | 1.2.8 to before 1.2.11 | 1.2.11 | Patch available | GHSA-v4p5-w6r3-2x4f |
- FUXA Vendorfrangoteam Affected 1.2.8 to before 1.2.11 Fixed in 1.2.11 Patch available CNA
- fuxa-server (npm) Vendor— Affected 1.2.8 to before 1.2.11 Fixed in 1.2.11 Patch available GHSA-v4p5-w6r3-2x4f
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:frangoteam:fuxa:*:*:*:*:*:*:*:* | 1.2.8 to before 1.2.11 | Vulnerable | frangoteam |
- cpe:2.3:a:frangoteam:fuxa:*:*:*:*:*:*:*:* Versions 1.2.8 to before 1.2.11 Vulnerable ·frangoteam
Remediation
- Fix · CNA FUXA (frangoteam) Fixed in 1.2.11
- Fix · GHSA-v4p5-w6r3-2x4f fuxa-server (npm) Fixed in 1.2.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25938
- 2026-10-03 Alias added: GHSA-v4p5-w6r3-2x4f
References
Advisory 2
More frangoteam Fuxa vulnerabilities
- TI-2025-42978 FUXA 1.2.8 and prior contains an Authentication Bypass vulnerability leading to Remote… CVSS 3.1CRITICAL 9.8
- TI-2023-16709 A remote command execution (RCE) vulnerability in the /api/runscript endpoint of FUXA… CVSS 3.1CRITICAL 9.8
- TI-2023-15187 FUXA <= 1.1.12 is vulnerable to SQL Injection via /api/signin. CVSS 3.1CRITICAL 9.8
- TI-2023-15186 FUXA <= 1.1.12 is vulnerable to Local via Inclusion via /api/download. CVSS 3.1HIGH 7.5
- TI-2023-15185 A SQL Injection attack in FUXA <= 1.1.12 allows exfiltration of confidential information from the database. CVSS 3.1HIGH 7.5
- TI-2026-20969 FUXA Unauthenticated Remote Arbitrary Scheduler Write CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-25938 · CVE Program
- CVE-2026-25938 · NVD
- FIRST EPSS
- GHSA-v4p5-w6r3-2x4f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences