Read the docs
TI-2026-21016 Aliases CVE-2026-26002

OnDemand susceptible to malicious input when navigating to a directory.

Priority LOW 31CWE-74Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

Open OnDemand is an open-source high-performance computing portal. The Files application in OnDemand versions prior to 4.0.9 and 4.1.3 is susceptible to malicious input when navigating to a directory. This has been patched in versions 4.0.9 and 4.1.3. Versions below this remain susceptible.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00607 49th percentileScored 2026-11-07
Fix Fixed ondemand (OSC): 4.0.9, 4.1.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
OSCondemandbefore 4.0.9; 4.1.0 to before 4.1.34.0.9, 4.1.3Patch availableCNA
  • ondemand VendorOSC Affected before 4.0.9; 4.1.0 to before 4.1.3 Fixed in 4.0.9, 4.1.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:osc:open_ondemand:*:*:*:*:*:*:*:*before 3.1.16; 4.0.0 to before 4.0.9; 4.1.0 to before 4.1.3VulnerableOSC
  • cpe:2.3:a:osc:open_ondemand:*:*:*:*:*:*:*:* Versions before 3.1.16; 4.0.0 to before 4.0.9; 4.1.0 to before 4.1.3 Vulnerable ·OSC

Remediation

  • Fix · CNA ondemand (OSC) Fixed in 4.0.9, 4.1.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-26002
  2. 2026-10-25 EPSS moved to the below the 50th percentile

References

  • TI-2020-18567 Open OnDemand before 1.5.7 and 1.6.x before 1.6.22 allows CSRF. CVSS 3.1HIGH 8.8
  • TI-2025-40555 Open OnDemand affected by Apache proxy passing sensitive headers CVSS 3.1HIGH 7.6

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences