Read the docs
TI-2026-21017 Aliases CVE-2026-26003

FastGPT Plugin forwarding request is not authenticated, posing a serious risk of attack

Priority LOW 36CWE-601Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Spoofing
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-601.

Summary

FastGPT is an AI Agent building platform. From 4.14.0 to 4.14.5, attackers can directly access the plugin system through FastGPT/api/plugin/xxx without authentication, thereby threatening the plugin system. This may cause the plugin system to crash and the loss of plugin installation status, but it will not result in key leakage. For older versions, as there are only operation interfaces for obtaining information, the impact is almost negligible. This vulnerability is fixed in 4.14.5-fix.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0027 19th percentileScored 2026-11-07
Fix Fixed FastGPT (labring): 4.14.5-fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
labringFastGPT4.14.0 to before 4.14.5-fix4.14.5-fixPatch availableCNA
  • FastGPT Vendorlabring Affected 4.14.0 to before 4.14.5-fix Fixed in 4.14.5-fix Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:fastgpt:fastgpt:*:*:*:*:*:*:*:*4.14.0 to before 4.14.5VulnerableFastgpt
cpe:2.3:a:fastgpt:fastgpt:4.14.5:-:*:*:*:*:*:*4.14.5VulnerableFastgpt
  • cpe:2.3:a:fastgpt:fastgpt:*:*:*:*:*:*:*:* Versions 4.14.0 to before 4.14.5 Vulnerable ·Fastgpt
  • cpe:2.3:a:fastgpt:fastgpt:4.14.5:-:*:*:*:*:*:* Versions 4.14.5 Vulnerable ·Fastgpt

Remediation

  • Fix · CNA FastGPT (labring) Fixed in 4.14.5-fix

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-26003

References

  • TI-2026-30610 FastGPT: Unauthenticated Remote Code Execution (RCE) via code-server Misconfiguration in agent-sandbox CVSS 3.1CRITICAL 9.8
  • TI-2026-48466 FastGPT: Unauthenticated WeChat channel hijack and denial of service via shareId-only authorization CVSS 4.0CRITICAL 9.3
  • TI-2026-44161 FastGPT: Unauthenticated cross-tenant data access via forgeable plugin-invoke JWT (default INVOKE_TOKEN_SECRET='token') CVSS 4.0HIGH 8.8
  • TI-2026-44148 Incorrect authorization in labring FastGPT CVSS 3.1HIGH 7.7
  • TI-2026-39440 FastGPT: SSRF in HTTP-tool OpenAPI schema importer via SwaggerParser $ref (bypasses the isInternalAddress guard) CVSS 3.1HIGH 7.7
  • TI-2026-30646 FastGPT: Uncontrolled Resource Consumption leading to Sandbox Exhaustion CVSS 4.0MEDIUM 6.3
See all 18 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences