GLPI has an Unauthenticated Stored XSS via inventory
Priority LOW 34CWE-116Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Security bypass, Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-306 and CWE-79.
Summary
GLPI is a free asset and IT management software package. From 11.0.0 to before 11.0.6, an unauthenticated user can store an XSS payload through the inventory endpoint. This vulnerability is fixed in 11.0.6.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00198 9th percentileScored 2026-11-07
Fix Fixed glpi (glpi-project): 11.0.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| glpi-project | glpi | 11.0.0 to before 11.0.6 | 11.0.6 | Patch available | CNA |
- glpi Vendorglpi-project Affected 11.0.0 to before 11.0.6 Fixed in 11.0.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* | 11.0.0 to before 11.0.6 | Vulnerable | glpi-project |
- cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* Versions 11.0.0 to before 11.0.6 Vulnerable ·glpi-project
Remediation
- Fix · CNA glpi (glpi-project) Fixed in 11.0.6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-26027
References
More glpi-project Glpi vulnerabilities
- TI-2022-16341 /vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection. KEVCVSS 3.1CRITICAL 9.8
- TI-2025-18516 GLPI allows unauthenticated SQL injection through the inventory endpoint CVSS 3.1CRITICAL 9.8
- TI-2023-25210 GLPI SQL injection through inventory agent request CVSS 3.1CRITICAL 9.8
- TI-2023-17986 GLPI vulnerable to SQL injection via inventory agent request CVSS 3.1CRITICAL 9.8
- TI-2022-13106 SQL injection on login page in GLPI CVSS 3.1CRITICAL 9.8
- TI-2023-18602 GLPI vulnerable to SQL injection through Computer Virtual Machine information CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences