Read the docs
TI-2026-21198 Aliases CVE-2026-26207

DIscourse's discourse-policy plugin lacks post access check

Priority LOW 24CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, `discourse-policy` plugin allows any authenticated user to interact with policies on posts they do not have permission to view. The `PolicyController` loads posts by ID without verifying the current user's access, enabling policy group members to accept/unaccept policies on posts in private categories or PMs they cannot see and any authenticated user to enumerate which post IDs have policies attached via differentiated error responses (information disclosure). The issue is patched in versions 2025.12.2, 2026.1.1, and 2026.2.0 by adding a `guardian.can_see?(@post)` check in the `set_post` before_action, ensuring post visibility is verified before any policy action is processed. As a workaround, disabling the discourse-policy plugin (`policy_enabled = false`) eliminates the vulnerability. There is no other workaround without upgrading.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00171 6th percentileScored 2026-11-07
Fix Fixed discourse (discourse): 2025.12.2, 2026.1.1, 2026.2.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
discoursediscoursebefore 2025.12.2; 2026.1.0-latest to before 2026.1.1; 2026.2.0-latest to before 2026.2.02025.12.2, 2026.1.1, 2026.2.0Patch availableCNA
  • discourse Vendordiscourse Affected before 2025.12.2; 2026.1.0-latest to before 2026.1.1; 2026.2.0-latest to before 2026.2.0 Fixed in 2025.12.2, 2026.1.1, 2026.2.0 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*before 2025.12.0; 2026.1.0 to before 2026.1.1Vulnerablediscourse
cpe:2.3:a:discourse:discourse:2026.2.0:*:*:*:latest:*:*:*2026.2.0Vulnerablediscourse
  • cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:* Versions before 2025.12.0; 2026.1.0 to before 2026.1.1 Vulnerable ·discourse
  • cpe:2.3:a:discourse:discourse:2026.2.0:*:*:*:latest:*:*:* Versions 2026.2.0 Vulnerable ·discourse

Remediation

  • Fix · CNA discourse (discourse) Fixed in 2025.12.2, 2026.1.1, 2026.2.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-26207

References

  • TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
  • TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
  • TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
  • TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
  • TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
  • TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
See all 262 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences