Sylde has Improper Control of Generation of Code
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-829.
Summary
Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Tygo-van-den-Hurk | Slyde | before 0.0.5 | 0.0.5 | Patch available | CNA |
| — | @tygo-van-den-hurk/slyde (npm) | before 0.0.5 | 0.0.5 | Patch available | GHSA-w7h5-55jg-cq2f |
- Slyde VendorTygo-van-den-Hurk Affected before 0.0.5 Fixed in 0.0.5 Patch available CNA
- @tygo-van-den-hurk/slyde (npm) Vendor— Affected before 0.0.5 Fixed in 0.0.5 Patch available GHSA-w7h5-55jg-cq2f
Remediation
- Fix · CNA Slyde (Tygo-van-den-Hurk) Fixed in 0.0.5
- Fix · GHSA-w7h5-55jg-cq2f @tygo-van-den-hurk/slyde (npm) Fixed in 0.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-26974
- 2026-10-03 Alias added: GHSA-w7h5-55jg-cq2f
- 2026-10-25 EPSS moved to the below the 50th percentile
References
Advisory 2
Sources
- CVE-2026-26974 · CVE Program
- CVE-2026-26974 · NVD
- FIRST EPSS
- GHSA-w7h5-55jg-cq2f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences