Cloud Hypervisor: Host File Exfiltration via QCOW Backing File Abuse
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-73 and the CVSS impact.
Summary
Cloud Hypervisor is a Virtual Machine Monitor for Cloud workloads. Versions 34.0 through 50.0 arevulnerable to arbitrary host file exfiltration (constrained by process privileges) when using virtio-block devices backed by raw images. A malicious guest can overwrite its disk header with a crafted QCOW2 structure pointing to a sensitive host path. Upon the next VM boot or disk scan, the image format auto-detection parses this header and serves the host file's contents to the guest. Guest-initiated VM reboots are sufficient to trigger a disk scan and do not cause the Cloud Hypervisor process to exit. Therefore, a single VM can perform this attack without needing interaction from the management stack. Successful exploitation requires the backing image to be either writable by the guest or sourced from an untrusted origin. Deployments utilizing only trusted, read-only images are not affected. This issue has been fixed in version 50.1. To workaround, enable land lock sandboxing and restrict process privileges and access.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| cloud-hypervisor | cloud-hypervisor | 34.0 to before 50.1 | 50.1 | Patch available | CNA |
- cloud-hypervisor Vendorcloud-hypervisor Affected 34.0 to before 50.1 Fixed in 50.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudhypervisor:cloud_hypervisor:*:*:*:*:*:rust:*:* | 34.0 to before 50.1 | Vulnerable | cloud-hypervisor |
- cpe:2.3:a:cloudhypervisor:cloud_hypervisor:*:*:*:*:*:rust:*:* Versions 34.0 to before 50.1 Vulnerable ·cloud-hypervisor
Remediation
- Fix · CNA cloud-hypervisor (cloud-hypervisor) Fixed in 50.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-27211
- 2026-10-19 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
References
Patch 4
- https://github.com/cloud-hypervisor/cloud-hypervisor/commit/081a6ebb5184228ff348601502258f3f72bd8b43
- https://github.com/cloud-hypervisor/cloud-hypervisor/commit/509832298b6865365b00bda88722e76e41ce7f41
- https://github.com/cloud-hypervisor/cloud-hypervisor/commit/a63315df54e06f6ec867f17b63076c266e2d8648
- https://github.com/cloud-hypervisor/cloud-hypervisor/commit/cb495959a8bea1b56e8fc82d15ba527a0e7fcf3c
Advisory 1
More cloud-hypervisor Cloud Hypervisor vulnerabilities
- TI-2023-14428 Malicious HTTP requests could close arbitrary opening file descriptors in cloud-hypervisor CVSS 3.1MEDIUM 4.9
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences