Acrobat Reader | Improper Certificate Validation (CWE-295)
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-295.
Summary
Acrobat Reader versions 24.001.30307, 24.001.30308, 25.001.21265 and earlier are affected by an Improper Certificate Validation vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to spoof the identity of a signer. Exploitation of this issue requires user interaction.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Acrobat DC | up to 25.001.21265 | 25.001.21288 | Patch available | CNA |
| Adobe | Acrobat Reader DC | up to 25.001.21265 | 25.001.21288 | Patch available | CNA |
| Adobe | Acrobat 2024 | up to 24.001.30307 (Win), 24.001.30308 (Mac) | 24.001.30356 | Patch available | CNA |
- Acrobat DC VendorAdobe Affected up to 25.001.21265 Fixed in 25.001.21288 Patch available CNA
- Acrobat Reader DC VendorAdobe Affected up to 25.001.21265 Fixed in 25.001.21288 Patch available CNA
- Acrobat 2024 VendorAdobe Affected up to 24.001.30307 (Win), 24.001.30308 (Mac) Fixed in 24.001.30356 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:acrobat_dc:*:*:*:*:continuous:*:*:* | before 25.001.21288 | Vulnerable | Adobe |
| cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Apple |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:a:adobe:acrobat_reader_dc:*:*:*:*:continuous:*:*:* | before 25.001.21288 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:acrobat:*:*:*:*:classic:*:*:* | 24.001.20604 to before 24.001.30356 | Vulnerable | Adobe |
- cpe:2.3:a:adobe:acrobat_dc:*:*:*:*:continuous:*:*:* Versions before 25.001.21288 Vulnerable ·Adobe
- cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Apple
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:a:adobe:acrobat_reader_dc:*:*:*:*:continuous:*:*:* Versions before 25.001.21288 Vulnerable ·Adobe
- cpe:2.3:a:adobe:acrobat:*:*:*:*:classic:*:*:* Versions 24.001.20604 to before 24.001.30356 Vulnerable ·Adobe
Remediation
- Fix · CNA Acrobat DC (Adobe) Fixed in 25.001.21288
- Fix · CNA Acrobat Reader DC (Adobe) Fixed in 25.001.21288
- Fix · CNA Acrobat 2024 (Adobe) Fixed in 24.001.30356
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Adobe Acrobat 2024, Acrobat DC, Acrobat Reader DC — helpx.adobe.com/security/products/acrobat/apsb26-26.html
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2026-21705 Acrobat Reader | Use After Free (CWE-416)Priority LOW 36
- TI-2026-21652 Acrobat Reader | Use After Free (CWE-416)Priority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2026-27221
- 2026-10-03 Alias added: GHSA-99cf-x4r7-cfg6
References
More Adobe Acrobat vulnerabilities
- TI-2014-00524 Adobe Reader and Acrobat 10.x before 10.1.11 and 11.x before 11.0.08 on Windows allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02915 Adobe Reader and Acrobat 9.x before 9.5.5, 10.x before 10.1.7, and 11.x before 11.0.03… KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02389 Integer overflow in Adobe Reader and Acrobat 9.x before 9.5.5, 10.x before 10.1.7, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2011-02156 Unspecified vulnerability in the U3D component in Adobe Reader and Acrobat 10.1.1 and… KEVCVSS 3.1CRITICAL 9.8
- TI-2021-09626 Adobe Acrobat Reader use after free vulnerability could lead to arbitrary code execution KEVCVSS 3.1HIGH 8.8
- TI-2021-04123 Acrobat Reader DC Heap-based Buffer Overflow Vulnerability Could Lead To Arbitrary Code Execution KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2026-27221 · CVE Program
- CVE-2026-27221 · NVD
- FIRST EPSS
- GHSA-99cf-x4r7-cfg6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences