Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 fixed, 19 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-770.
Summary
Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jashkenas | underscore | before 1.13.8 | 1.13.8 | Patch available | CNA |
| — | underscore (npm) | before 1.13.8 | 1.13.8 | Patch available | GHSA-qpx9-hpmf-5gmw |
- underscore Vendorjashkenas Affected before 1.13.8 Fixed in 1.13.8 Patch available CNA
- underscore (npm) Vendor— Affected before 1.13.8 Fixed in 1.13.8 Patch available GHSA-qpx9-hpmf-5gmw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:underscorejs:underscore:*:*:*:*:*:node.js:*:* | before 1.13.8 | Vulnerable | Underscorejs |
- cpe:2.3:a:underscorejs:underscore:*:*:*:*:*:node.js:*:* Versions before 1.13.8 Vulnerable ·Underscorejs
Remediation
- Fix · CNA underscore (jashkenas) Fixed in 1.13.8
- Fix · GHSA-qpx9-hpmf-5gmw underscore (npm) Fixed in 1.13.8 Advisory →
Red Hat 3 advisories
- RHSA-2026:24841 Released 2026-06-09 · Red Hat rating ModerateRed Hat Developer Hub 1.10.0 release.
- Red Hat Developer Hub 1.10 registry.redhat.io/rhdh/rhdh-hub-rhel9
- RHSA-2026:13826 Released 2026-05-05 · Red Hat rating CriticalRed Hat Developer Hub 1.9.4 release.
- Red Hat Developer Hub 1.9 registry.redhat.io/rhdh/rhdh-hub-rhel9, registry.redhat.io/rhdh/rhdh-rhel9-operator
- RHSA-2026:9742 Released 2026-04-22 · Red Hat rating CriticalRed Hat Developer Hub 1.8.6 release.
- Red Hat Developer Hub 1.8 registry.redhat.io/rhdh/rhdh-hub-rhel9, registry.redhat.io/rhdh/rhdh-rhel9-operator
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Logging Subsystem for Red Hat OpenShift | Affected | No fix yet: Fix deferred |
| Migration Toolkit for Virtualization | Affected | No fix yet: Fix deferred |
| OpenShift Pipelines | Affected | No fix yet: Fix deferred |
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix yet: Fix deferred |
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
| Red Hat Fuse 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 8 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform Expansion Pack | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Dev Spaces | Affected | No fix yet: Fix deferred |
| Red Hat Quay 3 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
| Self-service automation portal 2 | Affected | No fix yet: Fix deferred |
| Red Hat Developer Hub 1.10 | Fixed | RHSA-2026:24841 |
| Red Hat Developer Hub 1.8 | Fixed | RHSA-2026:9742 |
| Red Hat Developer Hub 1.9 | Fixed | RHSA-2026:13826 |
Not affected: 3 products
- Red Hat Developer Hub 1.10
- Red Hat Developer Hub 1.8
- Red Hat Developer Hub 1.9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-27601
- 2026-10-03 Alias added: GHSA-qpx9-hpmf-5gmw
References
Patch 2
More Underscorejs Underscore vulnerabilities
- TI-2021-06054 Arbitrary code injection in underscore CVSS 3.1HIGH 7.2
Sources
- CVE-2026-27601 · CVE Program
- CVE-2026-27601 · NVD
- FIRST EPSS
- GHSA-qpx9-hpmf-5gmw · GitHub Advisory Database · CC BY 4.0
- CVE-2026-27601 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences