Repostat Vulnerable to Reflected Cross-Site Scripting (XSS) via repo prop in RepoCard
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Repostat is a React component to fetch and display GitHub repository info. Prior to version 1.0.1, the `RepoCard` component is vulnerable to Reflected Cross-Site Scripting (XSS). The vulnerability occurs because the component uses React's `dangerouslySetInnerHTML` to render the repository name (`repo` prop) during the loading state without any sanitization. If a developer using this package passes unvalidated user input directly into the `repo` prop (for example, reading it from a URL query parameter), an attacker can execute arbitrary JavaScript in the context of the user's browser. In version 1.0.1, the use of dangerouslySetInnerHTML has been removed, and the repo prop is now safely rendered using standard React JSX data binding, which automatically escapes HTML entities.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| denpiligrim | repostat | before 1.0.1 | 1.0.1 | Patch available | CNA |
| — | repostat (npm) | before 1.0.1 | 1.0.1 | Patch available | GHSA-fm8c-6m29-rp6j |
- repostat Vendordenpiligrim Affected before 1.0.1 Fixed in 1.0.1 Patch available CNA
- repostat (npm) Vendor— Affected before 1.0.1 Fixed in 1.0.1 Patch available GHSA-fm8c-6m29-rp6j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:denpiligrim:repostat:*:*:*:*:*:node.js:*:* | before 1.0.1 | Vulnerable | denpiligrim |
- cpe:2.3:a:denpiligrim:repostat:*:*:*:*:*:node.js:*:* Versions before 1.0.1 Vulnerable ·denpiligrim
Remediation
- Fix · CNA repostat (denpiligrim) Fixed in 1.0.1
- Fix · GHSA-fm8c-6m29-rp6j repostat (npm) Fixed in 1.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-27612
- 2026-10-03 Alias added: GHSA-fm8c-6m29-rp6j
- 2026-11-03 CISA SSVC decision points changed
- 2026-11-03 Priority changed: LOW → MEDIUM
References
Sources
- CVE-2026-27612 · CVE Program
- CVE-2026-27612 · NVD
- FIRST EPSS
- GHSA-fm8c-6m29-rp6j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences