Read the docs
TI-2026-22245 Aliases CVE-2026-27901GHSA-phwv-c562-gvmh

Svelte vulnerable to XSS during SSR with contenteditable `bind:innerText` and `bind:textContent`

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Passive
Attack complexity
High
Attack requirements
Present
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · None · None
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Svelte performance oriented web framework. Prior to version 5.53.5, the contents of `bind:innerText` and `bind:textContent` on `contenteditable` elements were not properly escaped. This could enable HTML injection and Cross-Site Scripting (XSS) if rendering untrusted data as the binding's initial value on the server. Version 5.53.5 fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00257 17th percentileScored 2026-11-07
Fix Partial svelte (sveltejs): 5.53.5svelte (npm): 5.53.5Red Hat: 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
sveltejssveltebefore 5.53.55.53.5Patch availableCNA
—svelte (npm)before 5.53.55.53.5Patch availableGHSA-phwv-c562-gvmh
  • svelte Vendorsveltejs Affected before 5.53.5 Fixed in 5.53.5 Patch available CNA
  • svelte (npm) Vendor— Affected before 5.53.5 Fixed in 5.53.5 Patch available GHSA-phwv-c562-gvmh

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:svelte:svelte:*:*:*:*:*:node.js:*:*before 5.53.5Vulnerablesveltejs
cpe:2.3:a:svelte:svelte:5.53.5:*:*:*:*:node.js:*:*5.53.5Vulnerablesveltejs
  • cpe:2.3:a:svelte:svelte:*:*:*:*:*:node.js:*:* Versions before 5.53.5 Vulnerable ·sveltejs
  • cpe:2.3:a:svelte:svelte:5.53.5:*:*:*:*:node.js:*:* Versions 5.53.5 Vulnerable ·sveltejs

Remediation

  • Fix · CNA svelte (sveltejs) Fixed in 5.53.5
  • Fix · GHSA-phwv-c562-gvmh svelte (npm) Fixed in 5.53.5 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Build of Podman Desktop - Tech PreviewAffectedNo fix planned: Will not fix

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-27901
  2. 2026-10-03 Alias added: GHSA-phwv-c562-gvmh

References

  • TI-2024-30159 Potential mXSS vulnerability due to improper HTML escaping in svelte CVSS 3.1MEDIUM 6.1
  • TI-2025-13940 Svelte 5.46.0 - Hydratable Key Script-Breakout XSS (SSR) CVSS 4.0MEDIUM 5.3
  • TI-2021-10070 The unofficial Svelte extension before 104.8.0 for Visual Studio Code allows attackers to… CVSS 3.1HIGH 7.8
  • TI-2022-09436 Cross-site scripting (XSS) in svelte CVSS 3.1MEDIUM 6.1
  • TI-2026-30847 Svelte: ReDoS in `<svelte:element>` Tag Validation CVSS 4.0MEDIUM 5.9
  • TI-2026-30853 Svelte: XSS via DOM Clobbering of Internal Framework State CVSS 4.0MEDIUM 5.3
See all 12 →

Sources