Packistry accepts expired access tokens
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287.
Summary
Packistry is a self-hosted Composer repository designed to handle PHP package distribution. Prior to version 0.13.0, RepositoryAwareController::authorize() verified token presence and ability, but did not enforce token expiration. As a result, an expired deploy token with the correct ability could still access repository endpoints (e.g., Composer metadata/download APIs). The fix in version 0.13.0 adds an explicit expiration check, and tests now test expired deploy tokens to ensure they are rejected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| packistry | packistry | before 0.13.0 | 0.13.0 | Patch available | CNA |
- packistry Vendorpackistry Affected before 0.13.0 Fixed in 0.13.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:packistryphp:packistry:*:*:*:*:*:*:*:* | before 0.13.0 | Vulnerable | Packistryphp |
- cpe:2.3:a:packistryphp:packistry:*:*:*:*:*:*:*:* Versions before 0.13.0 Vulnerable ·Packistryphp
Remediation
- Fix · CNA packistry (packistry) Fixed in 0.13.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-27968
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences