Wagtail: Improper escaping of HTML (Cross-site Scripting) in simple_translation admin interface
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Wagtail is an open source content management system built on Django. Prior to versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1, a stored cross-site scripting (XSS) vulnerability exists on confirmation messages within the wagtail.contrib.simple_translation module. A user with access to the Wagtail admin area may create a page with a specially-crafted title which, when another user performs the "Translate" action, causes arbitrary JavaScript code to run. This could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wagtail | wagtail | before 6.3.8; 6.4rc1 to before 7.0.6; 7.1rc1 to before 7.2.3; 7.3rc1 to before 7.3.1 | 6.3.8, 7.0.6, 7.2.3, 7.3.1 | Patch available | CNA |
| — | wagtail (PyPI) | before 6.3.8 | 6.3.8 | Patch available | GHSA-p4v8-rw59-93cq |
| — | wagtail (PyPI) | 6.4rc1 to before 7.0.6 | 7.0.6 | Patch available | GHSA-p4v8-rw59-93cq |
| — | wagtail (PyPI) | 7.1rc1 to before 7.2.3 | 7.2.3 | Patch available | GHSA-p4v8-rw59-93cq |
| — | wagtail (PyPI) | 7.3rc1 to before 7.3.1 | 7.3.1 | Patch available | GHSA-p4v8-rw59-93cq |
- wagtail Vendorwagtail Affected before 6.3.8; 6.4rc1 to before 7.0.6; 7.1rc1 to before 7.2.3; 7.3rc1 to before 7.3.1 Fixed in 6.3.8, 7.0.6, 7.2.3, 7.3.1 Patch available CNA
- wagtail (PyPI) Vendor— Affected before 6.3.8 Fixed in 6.3.8 Patch available GHSA-p4v8-rw59-93cq
- wagtail (PyPI) Vendor— Affected 6.4rc1 to before 7.0.6 Fixed in 7.0.6 Patch available GHSA-p4v8-rw59-93cq
- wagtail (PyPI) Vendor— Affected 7.1rc1 to before 7.2.3 Fixed in 7.2.3 Patch available GHSA-p4v8-rw59-93cq
- wagtail (PyPI) Vendor— Affected 7.3rc1 to before 7.3.1 Fixed in 7.3.1 Patch available GHSA-p4v8-rw59-93cq
Remediation
- Fix · CNA wagtail (wagtail) Fixed in 6.3.8, 7.0.6, 7.2.3, 7.3.1
- Fix · GHSA-p4v8-rw59-93cq wagtail (PyPI) Fixed in 6.3.8 Advisory →
- Fix · GHSA-p4v8-rw59-93cq wagtail (PyPI) Fixed in 7.0.6 Advisory →
- Fix · GHSA-p4v8-rw59-93cq wagtail (PyPI) Fixed in 7.2.3 Advisory →
- Fix · GHSA-p4v8-rw59-93cq wagtail (PyPI) Fixed in 7.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-28223
- 2026-10-03 Alias added: GHSA-p4v8-rw59-93cq
References
Patch 4
- https://github.com/wagtail/wagtail/commit/1c6f2effed68f4ccad6fbd07987e03641505f863
- https://github.com/wagtail/wagtail/commit/ba70244d376a7b1bd180ded03e827917ff410c19
- https://github.com/wagtail/wagtail/commit/d8c5900982df8ed5938ad993aa9ff69cda50f80c
- https://github.com/wagtail/wagtail/commit/ee39d39deeb7f250fe886417b24802d7e05b1143
Advisory 2
More Wagtail vulnerabilities
- TI-2026-39163 Wagtail: Reflected XSS in dynamic image URL generator view CVSS 3.1HIGH 7.3
- TI-2020-08875 Possible XSS attack in Wagtail CVSS 3.1MEDIUM 6.8
- TI-2023-13342 Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views CVSS 3.1MEDIUM 6.4
- TI-2026-32180 Wagtail: Improper restriction handling on Documents and Images API CVSS 3.1MEDIUM 5.3
- TI-2026-22557 Wagtail: Improper escaping of HTML (Cross-site Scripting) on TableBlock class attributes CVSS 3.1MEDIUM 6.1
- TI-2024-26273 Wagtail regular expression denial-of-service via search query parsing CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-28223 · CVE Program
- CVE-2026-28223 · NVD
- FIRST EPSS
- GHSA-p4v8-rw59-93cq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences