In the query parser in OpenStack Vitrage before 12.0.1, 13.0.0, 14.0.0, and 15.0.0, a…
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-95.
Summary
In the query parser in OpenStack Vitrage before 12.0.1, 13.0.0, 14.0.0, and 15.0.0, a user allowed to access the Vitrage API may trigger code execution on the Vitrage service host as the user the Vitrage service runs under. This may result in unauthorized access to the host and further compromise of the Vitrage service. All deployments exposing the Vitrage API are affected. This occurs in _create_query_function in vitrage/graph/query.py.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenStack | Vitrage | before 12.0.1; 13.0.0; 14.0.0; 15.0.0 | 12.0.1 | Patch available | CNA |
| — | vitrage (PyPI) | 15.0.0.0rc1 to before 15.0.1 | 15.0.1 | Patch available | GHSA-8xwf-cr4r-856r |
| — | vitrage (PyPI) | 14.0.0.0rc1 to before 14.0.1 | 14.0.1 | Patch available | GHSA-8xwf-cr4r-856r |
| — | vitrage (PyPI) | 13.0.0.0rc1 to before 13.0.1 | 13.0.1 | Patch available | GHSA-8xwf-cr4r-856r |
| — | vitrage (PyPI) | before 12.0.1 | 12.0.1 | Patch available | GHSA-8xwf-cr4r-856r |
- Vitrage VendorOpenStack Affected before 12.0.1; 13.0.0; 14.0.0; 15.0.0 Fixed in 12.0.1 Patch available CNA
- vitrage (PyPI) Vendor— Affected 15.0.0.0rc1 to before 15.0.1 Fixed in 15.0.1 Patch available GHSA-8xwf-cr4r-856r
- vitrage (PyPI) Vendor— Affected 14.0.0.0rc1 to before 14.0.1 Fixed in 14.0.1 Patch available GHSA-8xwf-cr4r-856r
- vitrage (PyPI) Vendor— Affected 13.0.0.0rc1 to before 13.0.1 Fixed in 13.0.1 Patch available GHSA-8xwf-cr4r-856r
- vitrage (PyPI) Vendor— Affected before 12.0.1 Fixed in 12.0.1 Patch available GHSA-8xwf-cr4r-856r
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openstack:vitrage:*:*:*:*:*:*:*:* | before 12.01; 13.0.0 to before 13.0.1; 14.0.0 to before 14.0.1; 15.0.0 to before 15.0.1 | Vulnerable | OpenStack |
- cpe:2.3:a:openstack:vitrage:*:*:*:*:*:*:*:* Versions before 12.01; 13.0.0 to before 13.0.1; 14.0.0 to before 14.0.1; 15.0.0 to before 15.0.1 Vulnerable ·OpenStack
Remediation
- Fix · CNA Vitrage (OpenStack) Fixed in 12.0.1
- Fix · GHSA-8xwf-cr4r-856r vitrage (PyPI) Fixed in 15.0.1 Advisory →
- Fix · GHSA-8xwf-cr4r-856r vitrage (PyPI) Fixed in 14.0.1 Advisory →
- Fix · GHSA-8xwf-cr4r-856r vitrage (PyPI) Fixed in 13.0.1 Advisory →
- Fix · GHSA-8xwf-cr4r-856r vitrage (PyPI) Fixed in 12.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-28370
- 2026-10-03 Alias added: GHSA-8xwf-cr4r-856r
References
Sources
- CVE-2026-28370 · CVE Program
- CVE-2026-28370 · NVD
- FIRST EPSS
- GHSA-8xwf-cr4r-856r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences