OpenClaw 2.0.0-beta3 < 2026.2.14 - Arbitrary JavaScript Module Loading via Hook Transform Path Traversal
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-427.
Summary
OpenClaw versions 2.0.0-beta3 prior to 2026.2.14 contain a path traversal vulnerability in hook transform module loading that allows arbitrary JavaScript execution. The hooks.mappings[].transform.module parameter accepts absolute paths and traversal sequences, enabling attackers with configuration write access to load and execute malicious modules with gateway process privileges.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenClaw | OpenClaw | 2.0.0-beta3 to before 2026.2.14 | 2026.2.14 | Patch available | CNA |
| — | openclaw (npm) | 2.0.0-beta3 to before 2026.2.14 | 2026.2.14 | Patch available | GHSA-7xhj-55q9-pc3m |
- OpenClaw VendorOpenClaw Affected 2.0.0-beta3 to before 2026.2.14 Fixed in 2026.2.14 Patch available CNA
- openclaw (npm) Vendor— Affected 2.0.0-beta3 to before 2026.2.14 Fixed in 2026.2.14 Patch available GHSA-7xhj-55q9-pc3m
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:* | 2026.1.4 to before 2026.2.14 | Vulnerable | OpenClaw |
| cpe:2.3:a:openclaw:openclaw:2.0.0:beta3:*:*:*:node.js:*:* | 2.0.0 beta3 | Vulnerable | OpenClaw |
| cpe:2.3:a:openclaw:openclaw:2.0.0:beta4:*:*:*:node.js:*:* | 2.0.0 beta4 | Vulnerable | OpenClaw |
| cpe:2.3:a:openclaw:openclaw:2.0.0:beta5:*:*:*:node.js:*:* | 2.0.0 beta5 | Vulnerable | OpenClaw |
- cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:* Versions 2026.1.4 to before 2026.2.14 Vulnerable ·OpenClaw
- cpe:2.3:a:openclaw:openclaw:2.0.0:beta3:*:*:*:node.js:*:* Versions 2.0.0 beta3 Vulnerable ·OpenClaw
- cpe:2.3:a:openclaw:openclaw:2.0.0:beta4:*:*:*:node.js:*:* Versions 2.0.0 beta4 Vulnerable ·OpenClaw
- cpe:2.3:a:openclaw:openclaw:2.0.0:beta5:*:*:*:node.js:*:* Versions 2.0.0 beta5 Vulnerable ·OpenClaw
Remediation
- Fix · CNA OpenClaw (OpenClaw) Fixed in 2026.2.14
- Fix · GHSA-7xhj-55q9-pc3m openclaw (npm) Fixed in 2026.2.14 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
OpenClaw 2026.2.14
20 records Highest priority Priority MEDIUM 6 MEDIUM, 14 LOW
Other records, highest priority first
- TI-2026-23343 OpenClaw < 2026.2.14 - Denial of Service via Unbounded URL-backed Media FetchPriority MEDIUM 44
- TI-2026-23345 OpenClaw < 2026.2.14 - Local File Inclusion via mediaPath Parameter in BlueBubbles Media HandlingPriority MEDIUM 42
- TI-2026-22738 OpenClaw < 2026.2.14 - Cross-Account Policy Context Misrouting via Shared Webhook Path AmbiguityPriority MEDIUM 42
Timeline
- 2026-10-02 Threatist record created from CVE-2026-28393
- 2026-10-03 Alias added: GHSA-7xhj-55q9-pc3m
References
More Openclaw vulnerabilities
- TI-2026-25309 OpenClaw < 2026.3.28 Media Parsing Path Traversal to Arbitrary File Read CVSS 4.0HIGH 8.7
- TI-2026-20394 Exposure of resource to wrong sphere in OpenClaw CVSS 3.1HIGH 8.8
- TI-2026-27742 OpenClaw < 2026.3.24 - Arbitrary Code Execution via .npmrc in Local Plugin/Hook Installation CVSS 4.0HIGH 8.4
- TI-2026-27766 OpenClaw < 2026.3.24 - Denial of Service via Feishu Webhook Pre-Auth Body Parsing CVSS 4.0MEDIUM 6.9
- TI-2026-07315 OpenClaw bluebubbles Webhook monitor.ts handleBlueBubblesWebhookRequest improper authentication CVSS 4.0MEDIUM 6.9
- TI-2026-17789 OpenClaw < 2026.2.22 - Allowlist Bypass via Command Substitution in system.run CVSS 4.0HIGH 7.5
Sources
- CVE-2026-28393 · CVE Program
- CVE-2026-28393 · NVD
- FIRST EPSS
- GHSA-7xhj-55q9-pc3m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences