openDCIM <= 23.04 Missing Authorization in install.php
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
openDCIM version 23.04, through commit 4467e9c4, contains a missing authorization vulnerability in install.php and container-install.php. The installer and upgrade handler expose LDAP configuration functionality without enforcing application role checks. Any authenticated user can access this functionality regardless of assigned privileges. In deployments where REMOTE_USER is set without authentication enforcement, the endpoint may be accessible without credentials. This allows unauthorized modification of application configuration.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-28515
- 2026-10-03 Alias added: GHSA-mg2w-x76x-59h8
References
Exploit 2
Patch 2
More Opendcim vulnerabilities
- TI-2026-22779 openDCIM <= 23.04 OS Command Injection via dot Configuration Parameter CVSS 4.0CRITICAL 9.3
- TI-2026-22778 openDCIM <= 23.04 SQL Injection in Config::UpdateParameter CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-28515 · CVE Program
- CVE-2026-28515 · NVD
- FIRST EPSS
- GHSA-mg2w-x76x-59h8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences