jackson-core: Nesting Depth Constraint Bypass in `UTF8DataInputJsonParser` potentially allowing Resource Exhaustion
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
jackson-core contains core low-level incremental ("streaming") parser and generator abstractions used by Jackson Data Processor. From version 3.0.0 to before version 3.1.0, the UTF8DataInputJsonParser, which is used when parsing from a java.io.DataInput source, bypasses the maxNestingDepth constraint (default: 500) defined in StreamReadConstraints. A similar issue was found in ReaderBasedJsonParser. This allows a user to supply a JSON document with excessive nesting, which can cause a StackOverflowError when the structure is processed, leading to a Denial of Service (DoS). This issue has been patched in version 3.1.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| FasterXML | jackson-core | 3.0.0 to before 3.1.0 | 3.1.0 | Patch available | CNA |
| — | tools.jackson.core:jackson-core (Maven) | 3.0.0 to before 3.1.0 | 3.1.0 | Patch available | GHSA-6v53-7c9g-w56r |
- jackson-core VendorFasterXML Affected 3.0.0 to before 3.1.0 Fixed in 3.1.0 Patch available CNA
- tools.jackson.core:jackson-core (Maven) Vendor— Affected 3.0.0 to before 3.1.0 Fixed in 3.1.0 Patch available GHSA-6v53-7c9g-w56r
Remediation
- Fix · CNA jackson-core (FasterXML) Fixed in 3.1.0
- Fix · GHSA-6v53-7c9g-w56r tools.jackson.core:jackson-core (Maven) Fixed in 3.1.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Certificate System 10
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-29062
- 2026-10-03 Alias added: GHSA-6v53-7c9g-w56r
- 2026-10-25 EPSS moved to the below the 50th percentile
References
Patch 3
Advisory 2
Sources
- CVE-2026-29062 · CVE Program
- CVE-2026-29062 · NVD
- FIRST EPSS
- GHSA-6v53-7c9g-w56r · GitHub Advisory Database · CC BY 4.0
- CVE-2026-29062 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences