Read the docs
TI-2026-23369 Aliases CVE-2026-29783GHSA-g8r9-g2v8-jv6f

GitHub Copilot CLI allows for dangerous shell expansion patterns that enable arbitrary command execution

Priority LOW 35CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Active
Attack complexity
Low
Attack requirements
Present
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.

Summary

The shell tool within GitHub Copilot CLI versions prior to and including 0.0.422 can allow arbitrary code execution through crafted bash parameter expansion patterns. An attacker who can influence the commands executed by the agent (e.g., via prompt injection through repository files, MCP server responses, or user instructions) can exploit bash parameter transformation operators to execute hidden commands, bypassing the safety assessment that classifies commands as "read-only." This has been patched in version 0.0.423. The vulnerability stems from how the CLI's shell safety assessment evaluates commands before execution. The safety layer parses and classifies shell commands as either read-only (safe) or write-capable (requires user approval). However, several bash parameter expansion features can embed executable code within arguments to otherwise read-only commands, causing them to appear safe while actually performing arbitrary operations. The specific dangerous patterns are ${var@P}, ${var=value} / ${var:=value}, ${!var}, and nested $(cmd) or <(cmd) inside ${...} expansions. An attacker who can influence command text sent to the shell tool - for example, through prompt injection via malicious repository content (README files, code comments, issue bodies), compromised or malicious MCP server responses, or crafted user instructions containing obfuscated commands - could achieve arbitrary code execution on the user's workstation. This is possible even in permission modes that require user approval for write operations, since the commands can appear to use only read-only utilities to ultimately trigger write operations. Successful exploitation could lead to data exfiltration, file modification, or further system compromise.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00468 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed @github/copilot (npm): 0.0.423

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
GitHubcopilot-cliup to 0.0.422—No fix listedCNA
—@github/copilot (npm)before 0.0.4230.0.423Patch availableGHSA-g8r9-g2v8-jv6f
  • copilot-cli VendorGitHub Affected up to 0.0.422 Fixed in — No fix listed CNA
  • @github/copilot (npm) Vendor— Affected before 0.0.423 Fixed in 0.0.423 Patch available GHSA-g8r9-g2v8-jv6f

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:github:copilot_command_line_interface:*:*:*:*:*:*:*:*before 0.0.423VulnerableGitHub
  • cpe:2.3:a:github:copilot_command_line_interface:*:*:*:*:*:*:*:* Versions before 0.0.423 Vulnerable ·GitHub

Remediation

  • Fix · GHSA-g8r9-g2v8-jv6f @github/copilot (npm) Fixed in 0.0.423 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-29783
  2. 2026-10-03 Alias added: GHSA-g8r9-g2v8-jv6f
  3. 2026-11-03 CISA SSVC decision points changed

References

Sources