Webauthn Framework: allowed_origins collapses URL-like origins to host-only values, bypassing exact origin validation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-346.
Summary
web-auth/webauthn-lib is an open source set of PHP libraries and a Symfony bundle to allow developers to integrate that authentication mechanism into their web applications. Prior to 5.2.4, when allowed_origins is configured, CheckAllowedOrigins reduces URL-like values to their host component and accepts on host match alone. This makes exact origin policies impossible to express: scheme and port differences are silently ignored. This vulnerability is fixed in 5.2.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| web-auth | webauthn-framework | before 5.2.4 | 5.2.4 | Patch available | CNA |
| web-auth | webauthn-lib | before 5.2.4 | 5.2.4 | Patch available | CNA |
| web-auth | webauthn-symfony-bundle | before 5.2.4 | 5.2.4 | Patch available | CNA |
| — | web-auth/webauthn-framework (Packagist) | 5.2.0 to before 5.2.4 | 5.2.4 | Patch available | GHSA-f7pm-6hr8-7ggm |
| — | web-auth/webauthn-lib (Packagist) | 5.2.0 to before 5.2.4 | 5.2.4 | Patch available | GHSA-f7pm-6hr8-7ggm |
| — | web-auth/webauthn-symfony-bundle (Packagist) | 5.2.0 to before 5.2.4 | 5.2.4 | Patch available | GHSA-f7pm-6hr8-7ggm |
- webauthn-framework Vendorweb-auth Affected before 5.2.4 Fixed in 5.2.4 Patch available CNA
- webauthn-lib Vendorweb-auth Affected before 5.2.4 Fixed in 5.2.4 Patch available CNA
- webauthn-symfony-bundle Vendorweb-auth Affected before 5.2.4 Fixed in 5.2.4 Patch available CNA
- web-auth/webauthn-framework (Packagist) Vendor— Affected 5.2.0 to before 5.2.4 Fixed in 5.2.4 Patch available GHSA-f7pm-6hr8-7ggm
- web-auth/webauthn-lib (Packagist) Vendor— Affected 5.2.0 to before 5.2.4 Fixed in 5.2.4 Patch available GHSA-f7pm-6hr8-7ggm
- web-auth/webauthn-symfony-bundle (Packagist) Vendor— Affected 5.2.0 to before 5.2.4 Fixed in 5.2.4 Patch available GHSA-f7pm-6hr8-7ggm
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:spomky-labs:webauthn-lib:*:*:*:*:*:*:*:* | 5.2.0 to before 5.2.4 | Vulnerable | Spomky-labs |
| cpe:2.3:a:spomky-labs:webauthn-symfony-bundle:*:*:*:*:*:*:*:* | 5.2.0 to before 5.2.4 | Vulnerable | Spomky-labs |
| cpe:2.3:a:spomky-labs:webauthn_framwork:*:*:*:*:*:*:*:* | 5.2.0 to before 5.2.4 | Vulnerable | Spomky-labs |
- cpe:2.3:a:spomky-labs:webauthn-lib:*:*:*:*:*:*:*:* Versions 5.2.0 to before 5.2.4 Vulnerable ·Spomky-labs
- cpe:2.3:a:spomky-labs:webauthn-symfony-bundle:*:*:*:*:*:*:*:* Versions 5.2.0 to before 5.2.4 Vulnerable ·Spomky-labs
- cpe:2.3:a:spomky-labs:webauthn_framwork:*:*:*:*:*:*:*:* Versions 5.2.0 to before 5.2.4 Vulnerable ·Spomky-labs
Remediation
- Fix · CNA webauthn-framework (web-auth) Fixed in 5.2.4
- Fix · CNA webauthn-lib (web-auth) Fixed in 5.2.4
- Fix · CNA webauthn-symfony-bundle (web-auth) Fixed in 5.2.4
- Fix · GHSA-f7pm-6hr8-7ggm web-auth/webauthn-framework (Packagist) Fixed in 5.2.4 Advisory →
- Fix · GHSA-f7pm-6hr8-7ggm web-auth/webauthn-lib (Packagist) Fixed in 5.2.4 Advisory →
- Fix · GHSA-f7pm-6hr8-7ggm web-auth/webauthn-symfony-bundle (Packagist) Fixed in 5.2.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-30964
- 2026-10-03 Alias added: GHSA-f7pm-6hr8-7ggm
References
Patch 2
More web-auth vulnerabilities
- TI-2024-26806 Enumeration of valid usernames in web-auth/webauthn-lib CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-30964 · CVE Program
- CVE-2026-30964 · NVD
- FIRST EPSS
- GHSA-f7pm-6hr8-7ggm · GitHub Advisory Database · CC BY 4.0
- CVE-2026-30964 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences