Read the docs
TI-2026-24007 Aliases CVE-2026-31449GHSA-rq43-8p3g-5cc4

ext4: validate p_idx bounds in ext4_ext_correct_indexes

Priority LOW 35CWE-125Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 4 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.

Summary

In the Linux kernel, the following vulnerability has been resolved: ext4: validate p_idx bounds in ext4_ext_correct_indexes ext4_ext_correct_indexes() walks up the extent tree correcting index entries when the first extent in a leaf is modified. Before accessing path[k].p_idx->ei_block, there is no validation that p_idx falls within the valid range of index entries for that level. If the on-disk extent header contains a corrupted or crafted eh_entries value, p_idx can point past the end of the allocated buffer, causing a slab-out-of-bounds read. Fix this by validating path[k].p_idx against EXT_LAST_INDEX() at both access sites: before the while loop and inside it. Return -EFSCORRUPTED if the index pointer is out of range, consistent with how other bounds violations are handled in the ext4 extent tree code.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00147 3rd percentileScored 2026-11-07
Fix Partial Linux (Linux): 5.10.259, 5.15.210, 6.1.175 +5Red Hat: 4 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux2.6.19 and later5.10.259, 5.15.210, 6.1.175, 6.6.140, 6.12.80, 6.18.21, 6.19.11, 7.0Patch availableCNA
  • Linux VendorLinux Affected 2.6.19 and later Fixed in 5.10.259, 5.15.210, 6.1.175, 6.6.140, 6.12.80, 6.18.21, 6.19.11, 7.0 Patch available CNA

CPE configurations NVD · 12

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*2.6.19.1 to before 6.12.80; 6.13 to before 6.18.21; 6.19 to before 6.19.11VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.19:-:*:*:*:*:*:*2.6.19VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.19:rc2:*:*:*:*:*:*2.6.19 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.19:rc3:*:*:*:*:*:*2.6.19 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.19:rc4:*:*:*:*:*:*2.6.19 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.19:rc5:*:*:*:*:*:*2.6.19 rc5VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.19:rc6:*:*:*:*:*:*2.6.19 rc6VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:*7.0 rc1VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:*7.0 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:*7.0 rc3VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.19.1 to before 6.12.80; 6.13 to before 6.18.21; 6.19 to before 6.19.11 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.19:-:*:*:*:*:*:* Versions 2.6.19 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.19:rc2:*:*:*:*:*:* Versions 2.6.19 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.19:rc3:*:*:*:*:*:* Versions 2.6.19 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.19:rc4:*:*:*:*:*:* Versions 2.6.19 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.19:rc5:*:*:*:*:*:* Versions 2.6.19 rc5 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.19:rc6:*:*:*:*:*:* Versions 2.6.19 rc6 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* Versions 7.0 rc1 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* Versions 7.0 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:* Versions 7.0 rc3 Vulnerable ·Linux
Show 2 more CPE
CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:*7.0 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:*7.0 rc5VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:* Versions 7.0 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:* Versions 7.0 rc5 Vulnerable ·Linux

Remediation

  • Fix · CNA Linux (Linux) Fixed in 5.10.259, 5.15.210, 6.1.175, 6.6.140, 6.12.80, 6.18.21, 6.19.11, 7.0

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 10AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 7AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 8AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 9AffectedNo fix yet: Fix deferred
Not affected: 1 product
  • Red Hat Enterprise Linux 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-31449
  2. 2026-10-03 Alias added: GHSA-rq43-8p3g-5cc4
  3. 2026-10-16 CISA SSVC decision points changed
  4. 2026-10-19 Weakness changed · CISA ADP

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources