KVM: arm64: Fix the descriptor address in __kvm_at_swap_desc()
Priority LOW 37Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: KVM: arm64: Fix the descriptor address in __kvm_at_swap_desc() Using "(u64 __user *)hva + offset" to get the virtual addresses of S1/S2 descriptors looks really wrong, if offset is not zero. What we want to get for swapping is hva + offset, not hva + offset*8. ;-) Fix it.
Why it matters now
EPSS 0.0012 1st percentileScored 2026-11-07
Fix Fixed Linux (Linux): 6.19.11, 7.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.19 and later | 6.19.11, 7.0 | Patch available | CNA |
- Linux VendorLinux Affected 6.19 and later Fixed in 6.19.11, 7.0 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.19.1 to before 6.19.11 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.19:-:*:*:*:*:*:* | 6.19 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* | 7.0 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* | 7.0 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:* | 7.0 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:* | 7.0 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:* | 7.0 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc6:*:*:*:*:*:* | 7.0 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc7:*:*:*:*:*:* | 7.0 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.19.1 to before 6.19.11 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.19:-:*:*:*:*:*:* Versions 6.19 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* Versions 7.0 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* Versions 7.0 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc3:*:*:*:*:*:* Versions 7.0 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc4:*:*:*:*:*:* Versions 7.0 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc5:*:*:*:*:*:* Versions 7.0 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc6:*:*:*:*:*:* Versions 7.0 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc7:*:*:*:*:*:* Versions 7.0 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.19.11, 7.0
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-31553
- 2026-10-03 Alias added: GHSA-6xvj-cpww-rx88
- 2026-10-20 Affected versions changed · Red Hat
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-31553 · CVE Program
- CVE-2026-31553 · NVD
- FIRST EPSS
- GHSA-6xvj-cpww-rx88 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-31553 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences