Raw exposure of database statements in Hyperterse MCP search tool
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| hyperterse | hyperterse | 2.0.0 to before 2.2.0 | 2.2.0 | Patch available | CNA |
| — | hyperterse (npm) | 2.0.0 to before 2.2.0 | 2.2.0 | Patch available | GHSA-92gp-jfgx-9qpv |
- hyperterse Vendorhyperterse Affected 2.0.0 to before 2.2.0 Fixed in 2.2.0 Patch available CNA
- hyperterse (npm) Vendor— Affected 2.0.0 to before 2.2.0 Fixed in 2.2.0 Patch available GHSA-92gp-jfgx-9qpv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hyperterse:hyperterse:*:*:*:*:*:*:*:* | before 2.2.0 | Vulnerable | hyperterse |
- cpe:2.3:a:hyperterse:hyperterse:*:*:*:*:*:*:*:* Versions before 2.2.0 Vulnerable ·hyperterse
Remediation
- Fix · CNA hyperterse (hyperterse) Fixed in 2.2.0
- Fix · GHSA-92gp-jfgx-9qpv hyperterse (npm) Fixed in 2.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-31841
- 2026-10-03 Alias added: GHSA-92gp-jfgx-9qpv
References
Sources
- CVE-2026-31841 · CVE Program
- CVE-2026-31841 · NVD
- FIRST EPSS
- GHSA-92gp-jfgx-9qpv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences