Frappe: Possible SSRF by any authenticated user
Priority LOW 22CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-918 and the CVSS impact.
Summary
Frappe is a full-stack web application framework. Prior to 14.100.1, 15.100.0, and 16.6.0, a malicious user could send a crafted request to an endpoint which would lead to the server making an HTTP call to a service of the user's choice. This vulnerability is fixed in 14.100.1, 15.100.0, and 16.6.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00213 11th percentileScored 2026-11-07
Fix Fixed frappe (frappe): 16.6.0, 15.100.0, 14.100.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| frappe | frappe | 16.0.0 to before 16.6.0; 15.0.0 to before 15.100.0; before 14.100.1 | 16.6.0, 15.100.0, 14.100.1 | Patch available | CNA |
- frappe Vendorfrappe Affected 16.0.0 to before 16.6.0; 15.0.0 to before 15.100.0; before 14.100.1 Fixed in 16.6.0, 15.100.0, 14.100.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:frappe:frappe:*:*:*:*:*:*:*:* | before 14.100.1; 15.0.0 to before 15.100.0; 16.0.0 to before 16.6.0 | Vulnerable | frappe |
- cpe:2.3:a:frappe:frappe:*:*:*:*:*:*:*:* Versions before 14.100.1; 15.0.0 to before 15.100.0; 16.0.0 to before 16.6.0 Vulnerable ·frappe
Remediation
- Fix · CNA frappe (frappe) Fixed in 16.6.0, 15.100.0, 14.100.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-31878
References
More Frappe vulnerabilities
- TI-2025-35319 ERPNEXT v15.67.0 was discovered to contain multiple SQL injection vulnerabilities in the… CVSS 3.1MEDIUM 6.5
- TI-2025-35318 Frappe Framework v15.72.4 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1MEDIUM 6.5
- TI-2022-20104 Path traversal in Frappe CVSS 3.1MEDIUM 6.5
- TI-2025-35317 A stored cross-site scripting (XSS) vulnerability in the blog post feature of ERPNEXT… CVSS 3.1MEDIUM 5.4
- TI-2026-03168 Frappe Framework 16.10.0 - Stored DOM XSS in Tag Pill Renderer CVSS 4.0MEDIUM 4.6
- TI-2023-24769 Frappe vulnerable to HTML injection by any Desk user CVSS 3.1MEDIUM 5.4
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences