Dataease: Unfiltered active SVG content leads to Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Dataease is an open source data visualization analysis tool. In DataEase 2.10.19 and earlier, the static resource upload interface allows SVG uploads. However, backend validation only checks whether the XML is parseable and whether the root node is svg. It does not sanitize active content such as onload/onerror event handlers or script-capable attributes. As a result, an attacker can upload a malicious SVG and then trigger script execution in a browser by visiting the exposed static resource URL, forming a full stored XSS exploitation chain. This vulnerability is fixed in 2.10.20.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA dataease (dataease) Fixed in 2.10.20
Timeline
- 2026-10-02 Threatist record created from CVE-2026-32139
References
More Dataease vulnerabilities
- TI-2024-38037 An issue in DataEase v1 allows an attacker to execute arbitrary code via the user account and password components. CVSS 3.1CRITICAL 9.8
- TI-2023-12981 SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed CVSS 3.1CRITICAL 9.8
- TI-2022-18688 Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-24677 Dataease: Redshift JDBC RCE Bypass CVSS 4.0CRITICAL 9.3
- TI-2026-24674 DataEase SQL Injection Vulnerability CVSS 4.0CRITICAL 9.3
- TI-2024-37398 DataEase has an unauthorized vulnerability CVSS 4.0CRITICAL 9.3
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences