Discourse: XSS on category description update via API
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, updating a category description via API is not sanitizing the description string, which can lead to XSS attacks. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | discourse | 2026.1.0-latest to before 2026.1.3; 2026.2.0-latest to before 2026.2.2; 2026.3.0-latest to before 2026.3.0 | 2026.1.3, 2026.2.2, 2026.3.0 | Patch available | CNA |
- discourse Vendordiscourse Affected 2026.1.0-latest to before 2026.1.3; 2026.2.0-latest to before 2026.2.2; 2026.3.0-latest to before 2026.3.0 Fixed in 2026.1.3, 2026.2.2, 2026.3.0 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:discourse:discourse:*:*:*:*:latest:*:*:* | 2026.1.0 to before 2026.1.3; 2026.2.0 to before 2026.2.2 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2026.3.0:*:*:*:latest:*:*:* | 2026.3.0 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2026.3.0:*:*:*:latest.1:*:*:* | 2026.3.0 | Vulnerable | discourse |
- cpe:2.3:a:discourse:discourse:*:*:*:*:latest:*:*:* Versions 2026.1.0 to before 2026.1.3; 2026.2.0 to before 2026.2.2 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2026.3.0:*:*:*:latest:*:*:* Versions 2026.3.0 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2026.3.0:*:*:*:latest.1:*:*:* Versions 2026.3.0 Vulnerable ·discourse
Remediation
- Fix · CNA discourse (discourse) Fixed in 2026.1.3, 2026.2.2, 2026.3.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-32273
References
More Discourse vulnerabilities
- TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
- TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
- TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
- TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
- TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
- TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences