xml-security is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
xml-security is a library that implements XML signatures and encryption. Prior to versions 2.3.1 and 1.13.9, XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. This vulnerability is fixed in 2.3.1 and 1.13.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| simplesamlphp | xml-security | 2.0.0 to before 2.3.1; before 1.13.9 | 2.3.1, 1.13.9 | Patch available | CNA |
| — | simplesamlphp/xml-security (Packagist) | 2.0.0 to before 2.3.1 | 2.3.1 | Patch available | GHSA-r353-4845-pr5p |
| — | simplesamlphp/xml-security (Packagist) | before 1.13.9 | 1.13.9 | Patch available | GHSA-r353-4845-pr5p |
- xml-security Vendorsimplesamlphp Affected 2.0.0 to before 2.3.1; before 1.13.9 Fixed in 2.3.1, 1.13.9 Patch available CNA
- simplesamlphp/xml-security (Packagist) Vendor— Affected 2.0.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-r353-4845-pr5p
- simplesamlphp/xml-security (Packagist) Vendor— Affected before 1.13.9 Fixed in 1.13.9 Patch available GHSA-r353-4845-pr5p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:xml-security:*:*:*:*:*:*:*:* | before 1.13.9; 2.0.0 to before 2.3.1 | Vulnerable | simplesamlphp |
- cpe:2.3:a:simplesamlphp:xml-security:*:*:*:*:*:*:*:* Versions before 1.13.9; 2.0.0 to before 2.3.1 Vulnerable ·simplesamlphp
Remediation
- Fix · CNA xml-security (simplesamlphp) Fixed in 2.3.1, 1.13.9
- Fix · GHSA-r353-4845-pr5p simplesamlphp/xml-security (Packagist) Fixed in 2.3.1 Advisory →
- Fix · GHSA-r353-4845-pr5p simplesamlphp/xml-security (Packagist) Fixed in 1.13.9 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-32600
- 2026-10-03 Alias added: GHSA-r353-4845-pr5p
References
Patch 2
More simplesamlphp Xml-security vulnerabilities
- TI-2023-26752 Validation of SignedInfo CVSS 3.1HIGH 7.5
Sources
- CVE-2026-32600 · CVE Program
- CVE-2026-32600 · NVD
- FIRST EPSS
- GHSA-r353-4845-pr5p · GitHub Advisory Database · CC BY 4.0
- CVE-2026-32600 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences