PX4 autopilot has a stack buffer overflow in tattu_can due to unbounded memcpy in frame assembly loop
Key facts
- Attack vector
- Physical
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, tattu_can contains an unbounded memcpy in its multi-frame assembly loop, allowing stack memory overwrite when crafted CAN frames are processed. In deployments where tattu_can is enabled and running, a CAN-injection-capable attacker can trigger a crash (DoS) and memory corruption. This vulnerability is fixed in 1.17.0-rc2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PX4 | PX4-Autopilot | before 1.17.0-rc2 | 1.17.0-rc2 | Patch available | CNA |
- PX4-Autopilot VendorPX4 Affected before 1.17.0-rc2 Fixed in 1.17.0-rc2 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dronecode:px4_drone_autopilot:*:*:*:*:*:*:*:* | before 1.17.0 | Vulnerable | Dronecode |
| cpe:2.3:a:dronecode:px4_drone_autopilot:1.17.0:alpha1:*:*:*:*:*:* | 1.17.0 alpha1 | Vulnerable | Dronecode |
| cpe:2.3:a:dronecode:px4_drone_autopilot:1.17.0:beta1:*:*:*:*:*:* | 1.17.0 beta1 | Vulnerable | Dronecode |
| cpe:2.3:a:dronecode:px4_drone_autopilot:1.17.0:rc1:*:*:*:*:*:* | 1.17.0 rc1 | Vulnerable | Dronecode |
- cpe:2.3:a:dronecode:px4_drone_autopilot:*:*:*:*:*:*:*:* Versions before 1.17.0 Vulnerable ·Dronecode
- cpe:2.3:a:dronecode:px4_drone_autopilot:1.17.0:alpha1:*:*:*:*:*:* Versions 1.17.0 alpha1 Vulnerable ·Dronecode
- cpe:2.3:a:dronecode:px4_drone_autopilot:1.17.0:beta1:*:*:*:*:*:* Versions 1.17.0 beta1 Vulnerable ·Dronecode
- cpe:2.3:a:dronecode:px4_drone_autopilot:1.17.0:rc1:*:*:*:*:*:* Versions 1.17.0 rc1 Vulnerable ·Dronecode
Remediation
- Fix · CNA PX4-Autopilot (PX4) Fixed in 1.17.0-rc2
Timeline
- 2026-10-02 Threatist record created from CVE-2026-32707
References
More PX4 vulnerabilities
- TI-2023-24883 PX4-Autopilot Heap Buffer Overflow Bug CVSS 3.1CRITICAL 9.8
- TI-2026-25200 Zenoh uORB Subscriber Allows Arbitrary Stack Allocation (PX4/PX4-Autopilot) CVSS 3.1HIGH 8.0
- TI-2026-25198 PX4 autopilot has a global buffer overflow in crsf_rc via oversized variable-length known packet CVSS 3.1HIGH 8.1
- TI-2026-25197 PX4 autopilot BST Device Name Length Can Overflow Driver Buffer CVSS 3.1MEDIUM 6.8
- TI-2026-65506 PX4 Autopilot through 1.17.0 Stack Exhaustion via tests file2 Command CVSS 4.0HIGH 7.1
- TI-2026-59272 PX4 Autopilot through 1.17.0 Use-After-Free in load_mon CVSS 4.0HIGH 7.1
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences