Apache Airflow Provider for Databricks: TLS Certificate Verification Disabled in Databricks Provider K8s Token Exchange
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
Improper Certificate Validation vulnerability in Apache Airflow Provider for Databricks. Provider code did not validate certificates for connections to Databricks back-end which could result in a man-of-a-middle attack that traffic is intercepted and manipulated or credentials exfiltrated w/o notice. This issue affects Apache Airflow Provider for Databricks: from 1.10.0 before 1.12.0. Users are recommended to upgrade to version 1.12.0, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow Provider for Databricks | 1.10.0 to before 1.12.0 | 1.12.0 | Patch available | CNA |
| — | apache-airflow (PyPI) | 1.10.0 to before 1.12.0 | 1.12.0 | Patch available | GHSA-wrpj-755p-x363 |
- Apache Airflow Provider for Databricks VendorApache Affected 1.10.0 to before 1.12.0 Fixed in 1.12.0 Patch available CNA
- apache-airflow (PyPI) Vendor— Affected 1.10.0 to before 1.12.0 Fixed in 1.12.0 Patch available GHSA-wrpj-755p-x363
Remediation
- Fix · CNA Apache Airflow Provider for Databricks (Apache Software Foundation) Fixed in 1.12.0
- Fix · GHSA-wrpj-755p-x363 apache-airflow (PyPI) Fixed in 1.12.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-32794
- 2026-10-03 Alias added: GHSA-wrpj-755p-x363
References
Sources
- CVE-2026-32794 · CVE Program
- CVE-2026-32794 · NVD
- FIRST EPSS
- GHSA-wrpj-755p-x363 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences