Read the docs
TI-2026-25811 Aliases CVE-2026-33414GHSA-hc8w-h2mf-hp59

PowerShell Command Injection in Podman HyperV Machine

Priority LOW 28CWE-78Published · Updated

Key facts

Attack vector
Local
Privileges required
High
User interaction
None
Attack complexity
High
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-78.

Summary

Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00607 49th percentileScored 2026-11-07
Fix Fixed podman (containers): 5.8.2github.com/containers/podman/v5 (Go): 5.8.2Red Hat: 1 advisory

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
containerspodman4.8.0 to before 5.8.25.8.2Patch availableCNA
—github.com/containers/podman/v4 (Go)4.8.0 – 4.9.5—No fix listedGHSA-hc8w-h2mf-hp59
—github.com/containers/podman/v5 (Go)before 5.8.25.8.2Patch availableGHSA-hc8w-h2mf-hp59
  • podman Vendorcontainers Affected 4.8.0 to before 5.8.2 Fixed in 5.8.2 Patch available CNA
  • github.com/containers/podman/v4 (Go) Vendor— Affected 4.8.0 – 4.9.5 Fixed in — No fix listed GHSA-hc8w-h2mf-hp59
  • github.com/containers/podman/v5 (Go) Vendor— Affected before 5.8.2 Fixed in 5.8.2 Patch available GHSA-hc8w-h2mf-hp59

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:podman_project:podman:*:*:*:*:*:*:*:*4.8.0 to before 5.8.2VulnerablePodman Project
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*not specified by NVDRunning onMicrosoft
  • cpe:2.3:a:podman_project:podman:*:*:*:*:*:*:*:* Versions 4.8.0 to before 5.8.2 Vulnerable ·Podman Project
  • cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft

Remediation

  • Fix · CNA podman (containers) Fixed in 5.8.2
  • Fix · GHSA-hc8w-h2mf-hp59 github.com/containers/podman/v5 (Go) Fixed in 5.8.2 Advisory →

Red Hat 1 advisory

  • RHSA-2026:8211 Released 2026-04-14 · Red Hat rating Important
    Red Hat Hardened Images RPMs bug fix and enhancement update
    • Red Hat Hardened Images podman-5.8.2-1.hum1@aarch64, podman-5.8.2-1.hum1@src, podman-5.8.2-1.hum1@x86_64 +10

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Hardened ImagesFixed RHSA-2026:8211
Not affected: 4 products
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-33414
  2. 2026-10-03 Alias added: GHSA-hc8w-h2mf-hp59
  3. 2026-10-25 EPSS moved to the below the 50th percentile

References

  • TI-2025-18645 .krun_config.json symlink attack creates or overwrites file on the host in crun CVSS 4.0HIGH 8.5
  • TI-2026-23721 Crun incorrectly parses `crun exec` option `-u`, leading to privilege escalation CVSS 3.1HIGH 7.8
  • TI-2026-37901 fuse-overlayfs release-1.x preserves SUID/SGID bits after truncate/open(O_TRUNC) CVSS 4.0LOW 2.0
  • TI-2026-29788 bubblewrap vulnerable to privilege escalation in setuid mode via ptrace CVSS 4.0HIGH 8.7
  • TI-2024-07805 Containers/aardvark-dns: tcp query handling flaw in aardvark-dns leading to denial of service CVSS 3.1HIGH 7.5
  • TI-2024-08665 Podman: buildah: cri-o: fips crypto-policy directory mounting issue in containers/common go library CVSS 3.1HIGH 8.2
See all 11 →

Sources