PrestaShop has multiple stored XSS vulnerabilities via unprotected Template variables
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 are vulnerable to stored Cross-Site Scripting (stored XSS) vulnerabilities in the BO. An attacker who can inject data into the database, via limited back-office access or a previously existing vulnerability, can exploit unprotected variables in back-office templates. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PrestaShop | PrestaShop | 9.0.0-alpha.1 to before 9.1.0; before 8.2.5 | 9.1.0, 8.2.5 | Patch available | CNA |
| — | prestashop/prestashop (Packagist) | 9.0.0-alpha.1 to before 9.1.0 | 9.1.0 | Patch available | GHSA-35pf-37c6-jxjv |
| — | prestashop/prestashop (Packagist) | before 8.2.5 | 8.2.5 | Patch available | GHSA-35pf-37c6-jxjv |
- PrestaShop VendorPrestaShop Affected 9.0.0-alpha.1 to before 9.1.0; before 8.2.5 Fixed in 9.1.0, 8.2.5 Patch available CNA
- prestashop/prestashop (Packagist) Vendor— Affected 9.0.0-alpha.1 to before 9.1.0 Fixed in 9.1.0 Patch available GHSA-35pf-37c6-jxjv
- prestashop/prestashop (Packagist) Vendor— Affected before 8.2.5 Fixed in 8.2.5 Patch available GHSA-35pf-37c6-jxjv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* | before 8.2.5; 9.0.0 to before 9.1.0 | Vulnerable | PrestaShop |
- cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* Versions before 8.2.5; 9.0.0 to before 9.1.0 Vulnerable ·PrestaShop
Remediation
- Fix · CNA PrestaShop (PrestaShop) Fixed in 9.1.0, 8.2.5
- Fix · GHSA-35pf-37c6-jxjv prestashop/prestashop (Packagist) Fixed in 9.1.0 Advisory →
- Fix · GHSA-35pf-37c6-jxjv prestashop/prestashop (Packagist) Fixed in 8.2.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-33673
- 2026-10-03 Alias added: GHSA-35pf-37c6-jxjv
References
Advisory 2
More Prestashop vulnerabilities
- TI-2024-27717 An issue in Prestashop v.8.1.7 and before allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2024-23013 PrestaShop vulnerable to XSS via customer contact form in FO, through file upload CVSS 3.1CRITICAL 9.7
- TI-2018-06367 modules/bamegamenu/ajax_phpcode.php in the Responsive Mega Menu… CVSS 3.0CRITICAL 9.8
- TI-2025-19098 A PHAR deserialization vulnerability in the _getHeaders function of PrestaShop v8.2.0… CVSS 3.1MEDIUM 6.5
- TI-2018-13560 PrestaShop 1.6.x before 1.6.1.23 and 1.7.x before 1.7.4.4 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2021-02206 The store system in PrestaShop 1.7.7.0 allows time-based boolean SQL injection via the… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-33673 · CVE Program
- CVE-2026-33673 · NVD
- FIRST EPSS
- GHSA-35pf-37c6-jxjv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences