Read the docs
TI-2026-26054 Aliases CVE-2026-33674GHSA-283w-xf3q-788v

PrestaShop: Improper Use of Validation Framework

Priority LOW 24CWE-1173Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 improperly use the validation framework. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00246 15th percentileScored 2026-11-07
Fix Fixed PrestaShop (PrestaShop): 8.2.5, 9.1.0prestashop/prestashop (Packagist): 8.2.5, 9.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PrestaShopPrestaShopbefore 8.2.5; 9.0.0-alpha.1 to before 9.1.08.2.5, 9.1.0Patch availableCNA
—prestashop/prestashop (Packagist)before 8.2.58.2.5Patch availableGHSA-283w-xf3q-788v
—prestashop/prestashop (Packagist)9.0.0-alpha.1 to before 9.1.09.1.0Patch availableGHSA-283w-xf3q-788v
  • PrestaShop VendorPrestaShop Affected before 8.2.5; 9.0.0-alpha.1 to before 9.1.0 Fixed in 8.2.5, 9.1.0 Patch available CNA
  • prestashop/prestashop (Packagist) Vendor— Affected before 8.2.5 Fixed in 8.2.5 Patch available GHSA-283w-xf3q-788v
  • prestashop/prestashop (Packagist) Vendor— Affected 9.0.0-alpha.1 to before 9.1.0 Fixed in 9.1.0 Patch available GHSA-283w-xf3q-788v

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:*before 8.2.5; 9.0.0 to before 9.1.0VulnerablePrestaShop
  • cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* Versions before 8.2.5; 9.0.0 to before 9.1.0 Vulnerable ·PrestaShop

Remediation

  • Fix · CNA PrestaShop (PrestaShop) Fixed in 8.2.5, 9.1.0
  • Fix · GHSA-283w-xf3q-788v prestashop/prestashop (Packagist) Fixed in 8.2.5 Advisory →
  • Fix · GHSA-283w-xf3q-788v prestashop/prestashop (Packagist) Fixed in 9.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-33674
  2. 2026-10-03 Alias added: GHSA-283w-xf3q-788v

References

  • TI-2024-27717 An issue in Prestashop v.8.1.7 and before allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
  • TI-2024-23013 PrestaShop vulnerable to XSS via customer contact form in FO, through file upload CVSS 3.1CRITICAL 9.7
  • TI-2018-06367 modules/bamegamenu/ajax_phpcode.php in the Responsive Mega Menu… CVSS 3.0CRITICAL 9.8
  • TI-2025-19098 A PHAR deserialization vulnerability in the _getHeaders function of PrestaShop v8.2.0… CVSS 3.1MEDIUM 6.5
  • TI-2018-13560 PrestaShop 1.6.x before 1.6.1.23 and 1.7.x before 1.7.4.4 allows remote attackers to… CVSS 3.0CRITICAL 9.8
  • TI-2021-02206 The store system in PrestaShop 1.7.7.0 allows time-based boolean SQL injection via the… CVSS 3.1CRITICAL 9.8
See all 92 →

Sources