Ruby LSP has arbitrary code execution through branch setting
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| remix-run | ruby-lsp | before 0.26.9 | 0.26.9 | Patch available | CNA |
| remix-run | Shopify.ruby-lsp | before 0.10.2 | 0.10.2 | Patch available | CNA |
| — | ruby-lsp (RubyGems) | before 0.26.9 | 0.26.9 | Patch available | GHSA-c4r5-fxqw-vh93 |
Remediation
- Fix · CNA ruby-lsp (Shopify) Fixed in 0.26.9
- Fix · CNA Shopify.ruby-lsp (Shopify) Fixed in 0.10.2
- Fix · GHSA-c4r5-fxqw-vh93 ruby-lsp (RubyGems) Fixed in 0.26.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-34060
- 2026-10-03 Alias added: GHSA-c4r5-fxqw-vh93
References
Advisory 2
Sources
- CVE-2026-34060 · CVE Program
- CVE-2026-34060 · NVD
- FIRST EPSS
- GHSA-c4r5-fxqw-vh93 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences