Exposure of resource to wrong sphere in Wikimedia Foundation MediaWiki
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Passive
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-668 and the CVSS impact.
Summary
Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/Page/Article.Php. This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | MediaWiki | before 1.43.7, 1.44.4, 1.45.2 | 1.43.7, 1.44.4, 1.45.2 | Patch available | CNA |
- MediaWiki VendorWikimedia Foundation Affected before 1.43.7, 1.44.4, 1.45.2 Fixed in 1.43.7, 1.44.4, 1.45.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* | before 1.43.7; 1.44.0 to before 1.44.4; 1.45.0 to before 1.45.2 | Vulnerable | mediawiki |
- cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions before 1.43.7; 1.44.0 to before 1.44.4; 1.45.0 to before 1.45.2 Vulnerable ·mediawiki
Remediation
- Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.43.7, 1.44.4, 1.45.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Wikimedia Foundation MediaWiki 1.43.7, 1.44.4, 1.45.2
6 records Highest priority Priority LOW 6 LOW
Other records, highest priority first
- TI-2026-26413 User localization leaked by AbuseFilter + EventStreamPriority LOW 31
- TI-2026-26414 Block UI elements in 'tools'-sidebar shows presence of an autoblocked IPPriority LOW 11
- TI-2026-26410 RecentChanges entries expose suppressed content via generated log page htmlPriority LOW 8
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-34094
- 2026-10-03 Alias added: GHSA-g863-m67x-whh5
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-34094 · CVE Program
- CVE-2026-34094 · NVD
- FIRST EPSS
- GHSA-g863-m67x-whh5 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-34094 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences