Read the docs
TI-2026-26449 Aliases CVE-2026-34148GHSA-gm9m-gwc4-hwgp

Fedify affected by resource exhaustion caused by unbounded redirect following during remote key/document resolution

Priority HIGH 72CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Prior to 1.9.6, 1.10.5, 2.0.8, and 2.1.1, @fedify/fedify follows HTTP redirects recursively in its remote document loader and authenticated document loader without enforcing a maximum redirect count or visited-URL loop detection. An attacker who controls a remote ActivityPub key or actor URL can force a server using Fedify to make repeated outbound requests from a single inbound request, leading to resource consumption and denial of service. This vulnerability is fixed in 1.9.6, 1.10.5, 2.0.8, and 2.1.1.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00572 47th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed fedify (@fedify): 1.9.6, 1.10.5, 2.0.8 +1vocab-runtime (@fedify): 2.0.8, 2.1.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
@fedifyfedifybefore 1.9.6; 1.10.0 to before 1.10.5; 2.0.0 to before 2.0.8; 2.1.0 to before 2.1.11.9.6, 1.10.5, 2.0.8, 2.1.1Patch availableCNA
@fedifyvocab-runtimebefore 2.0.8; 2.1.0 to before 2.1.12.0.8, 2.1.1Patch availableCNA
—@fedify/fedify (npm)before 1.9.61.9.6Patch availableGHSA-gm9m-gwc4-hwgp
—@fedify/vocab-runtime (npm)before 2.0.82.0.8Patch availableGHSA-gm9m-gwc4-hwgp
—@fedify/vocab-runtime (npm)2.1.0 to before 2.1.12.1.1Patch availableGHSA-gm9m-gwc4-hwgp
—@fedify/fedify (npm)1.10.0 to before 1.10.51.10.5Patch availableGHSA-gm9m-gwc4-hwgp
—@fedify/fedify (npm)2.0.0 to before 2.0.82.0.8Patch availableGHSA-gm9m-gwc4-hwgp
—@fedify/fedify (npm)2.1.0 to before 2.1.12.1.1Patch availableGHSA-gm9m-gwc4-hwgp
  • fedify Vendor@fedify Affected before 1.9.6; 1.10.0 to before 1.10.5; 2.0.0 to before 2.0.8; 2.1.0 to before 2.1.1 Fixed in 1.9.6, 1.10.5, 2.0.8, 2.1.1 Patch available CNA
  • vocab-runtime Vendor@fedify Affected before 2.0.8; 2.1.0 to before 2.1.1 Fixed in 2.0.8, 2.1.1 Patch available CNA
  • @fedify/fedify (npm) Vendor— Affected before 1.9.6 Fixed in 1.9.6 Patch available GHSA-gm9m-gwc4-hwgp
  • @fedify/vocab-runtime (npm) Vendor— Affected before 2.0.8 Fixed in 2.0.8 Patch available GHSA-gm9m-gwc4-hwgp
  • @fedify/vocab-runtime (npm) Vendor— Affected 2.1.0 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-gm9m-gwc4-hwgp
  • @fedify/fedify (npm) Vendor— Affected 1.10.0 to before 1.10.5 Fixed in 1.10.5 Patch available GHSA-gm9m-gwc4-hwgp
  • @fedify/fedify (npm) Vendor— Affected 2.0.0 to before 2.0.8 Fixed in 2.0.8 Patch available GHSA-gm9m-gwc4-hwgp
  • @fedify/fedify (npm) Vendor— Affected 2.1.0 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-gm9m-gwc4-hwgp

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:fedify:fedify\/fedify:*:*:*:*:*:node.js:*:*before 1.9.6; 1.10.0 to before 1.10.5; 2.0.0 to before 2.0.8; 2.1.0 to before 2.1.1Vulnerable@fedify
cpe:2.3:a:fedify:fedify\/vocab-runtime:*:*:*:*:*:node.js:*:*before 2.0.8; 2.1.0 to before 2.1.1Vulnerable@fedify
  • cpe:2.3:a:fedify:fedify\/fedify:*:*:*:*:*:node.js:*:* Versions before 1.9.6; 1.10.0 to before 1.10.5; 2.0.0 to before 2.0.8; 2.1.0 to before 2.1.1 Vulnerable ·@fedify
  • cpe:2.3:a:fedify:fedify\/vocab-runtime:*:*:*:*:*:node.js:*:* Versions before 2.0.8; 2.1.0 to before 2.1.1 Vulnerable ·@fedify

Remediation

  • Fix · CNA fedify (@fedify) Fixed in 1.9.6, 1.10.5, 2.0.8, 2.1.1
  • Fix · CNA vocab-runtime (@fedify) Fixed in 2.0.8, 2.1.1
  • Fix · GHSA-gm9m-gwc4-hwgp @fedify/fedify (npm) Fixed in 1.9.6 Advisory →
  • Fix · GHSA-gm9m-gwc4-hwgp @fedify/vocab-runtime (npm) Fixed in 2.0.8 Advisory →
  • Fix · GHSA-gm9m-gwc4-hwgp @fedify/vocab-runtime (npm) Fixed in 2.1.1 Advisory →
  • Fix · GHSA-gm9m-gwc4-hwgp @fedify/fedify (npm) Fixed in 1.10.5 Advisory →
  • Fix · GHSA-gm9m-gwc4-hwgp @fedify/fedify (npm) Fixed in 2.0.8 Advisory →
  • Fix · GHSA-gm9m-gwc4-hwgp @fedify/fedify (npm) Fixed in 2.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-34148
  2. 2026-10-03 Alias added: GHSA-gm9m-gwc4-hwgp
  3. 2026-10-25 EPSS moved to the below the 50th percentile

References

Sources