Read the docs
TI-2026-26494 Aliases CVE-2026-34197GHSA-rxpj-7qvf-xv32

Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans

Priority CRITICAL 97Exploited in the wildCWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue

Why it matters now

Exploitation Active In CISA KEV since 2026-04-16CISA due date 2026-04-30
EPSS 0.98256 99th percentileScored 2026-11-07
Fix Fixed Apache ActiveMQ Broker (Apache Software Foundation): 5.19.4, 6.2.3Apache ActiveMQ All (Apache Software Foundation): 5.19.4, 6.2.3+3 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache ActiveMQ Brokerbefore 5.19.4; 6.0.0 to before 6.2.35.19.4, 6.2.3Patch availableCNA
ApacheApache ActiveMQ Allbefore 5.19.4; 6.0.0 to before 6.2.35.19.4, 6.2.3Patch availableCNA
ApacheApache ActiveMQbefore 5.19.4; 6.0.0 to before 6.2.35.19.4, 6.2.3Patch availableCNA
—org.apache.activemq:activemq-broker (Maven)before 5.19.55.19.5Patch availableGHSA-rxpj-7qvf-xv32
—org.apache.activemq:activemq-broker (Maven)6.0.0 to before 6.2.36.2.3Patch availableGHSA-rxpj-7qvf-xv32
—org.apache.activemq:activemq-all (Maven)before 5.19.55.19.5Patch availableGHSA-rxpj-7qvf-xv32
—org.apache.activemq:activemq-all (Maven)6.0.0 to before 6.2.36.2.3Patch availableGHSA-rxpj-7qvf-xv32
  • Apache ActiveMQ Broker VendorApache Affected before 5.19.4; 6.0.0 to before 6.2.3 Fixed in 5.19.4, 6.2.3 Patch available CNA
  • Apache ActiveMQ All VendorApache Affected before 5.19.4; 6.0.0 to before 6.2.3 Fixed in 5.19.4, 6.2.3 Patch available CNA
  • Apache ActiveMQ VendorApache Affected before 5.19.4; 6.0.0 to before 6.2.3 Fixed in 5.19.4, 6.2.3 Patch available CNA
  • org.apache.activemq:activemq-broker (Maven) Vendor— Affected before 5.19.5 Fixed in 5.19.5 Patch available GHSA-rxpj-7qvf-xv32
  • org.apache.activemq:activemq-broker (Maven) Vendor— Affected 6.0.0 to before 6.2.3 Fixed in 6.2.3 Patch available GHSA-rxpj-7qvf-xv32
  • org.apache.activemq:activemq-all (Maven) Vendor— Affected before 5.19.5 Fixed in 5.19.5 Patch available GHSA-rxpj-7qvf-xv32
  • org.apache.activemq:activemq-all (Maven) Vendor— Affected 6.0.0 to before 6.2.3 Fixed in 6.2.3 Patch available GHSA-rxpj-7qvf-xv32

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*before 5.19.4; 6.0.0 to before 6.2.3VulnerableApache
cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:*before 5.19.4; 6.0.0 to before 6.2.3VulnerableApache
  • cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* Versions before 5.19.4; 6.0.0 to before 6.2.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:* Versions before 5.19.4; 6.0.0 to before 6.2.3 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache ActiveMQ Broker (Apache Software Foundation) Fixed in 5.19.4, 6.2.3
  • Fix · CNA Apache ActiveMQ All (Apache Software Foundation) Fixed in 5.19.4, 6.2.3
  • Fix · CNA Apache ActiveMQ (Apache Software Foundation) Fixed in 5.19.4, 6.2.3
  • Fix · GHSA-rxpj-7qvf-xv32 org.apache.activemq:activemq-broker (Maven) Fixed in 5.19.5 Advisory →
  • Fix · GHSA-rxpj-7qvf-xv32 org.apache.activemq:activemq-broker (Maven) Fixed in 6.2.3 Advisory →
  • Fix · GHSA-rxpj-7qvf-xv32 org.apache.activemq:activemq-all (Maven) Fixed in 5.19.5 Advisory →
  • Fix · GHSA-rxpj-7qvf-xv32 org.apache.activemq:activemq-all (Maven) Fixed in 6.2.3 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 8 products
  • Red Hat AMQ Broker 7
  • Red Hat Data Grid 8
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat Fuse 7
  • Red Hat JBoss Enterprise Application Platform 7
  • Red Hat JBoss Enterprise Application Platform 8
  • Red Hat JBoss Enterprise Application Platform Expansion Pack

Timeline

  1. 2026-04-16 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2026-34197
  3. 2026-10-03 Alias added: GHSA-rxpj-7qvf-xv32
  4. 2026-10-25 EPSS moved to the 99th percentile and above

References

  • TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
  • TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
  • TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
  • TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
  • TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
  • TI-2021-04444 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
See all 74 →

Sources