alerta-server has potential SQL Injection vulnerability in Query String Syntax (q=) API
Priority LOW 39CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Alerta is a monitoring tool. Prior to version 9.1.0, the Query string search API (q=) was vulnerable to SQL injection via the Postgres query parser, which built WHERE clauses by interpolating user-supplied search terms directly into SQL strings via f-strings. This issue has been patched in version 9.1.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00525 44th percentileScored 2026-11-07
Fix Fixed alerta (alerta): 9.1.0alerta-server (PyPI): 9.1.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| alerta | alerta | before 9.1.0 | 9.1.0 | Patch available | CNA |
| — | alerta-server (PyPI) | before 9.1.0 | 9.1.0 | Patch available | GHSA-8prr-286p-4w7j |
- alerta Vendoralerta Affected before 9.1.0 Fixed in 9.1.0 Patch available CNA
- alerta-server (PyPI) Vendor— Affected before 9.1.0 Fixed in 9.1.0 Patch available GHSA-8prr-286p-4w7j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:alerta_project:alerta:*:*:*:*:*:*:*:* | before 9.1.0 | Vulnerable | Alerta Project |
- cpe:2.3:a:alerta_project:alerta:*:*:*:*:*:*:*:* Versions before 9.1.0 Vulnerable ·Alerta Project
Remediation
- Fix · CNA alerta (alerta) Fixed in 9.1.0
- Fix · GHSA-8prr-286p-4w7j alerta-server (PyPI) Fixed in 9.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-34400
- 2026-10-03 Alias added: GHSA-8prr-286p-4w7j
References
Patch 4
Advisory 2
More Alerta Project Alerta vulnerabilities
- TI-2020-16035 LDAP authentication bypass in Alerta CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-34400 · CVE Program
- CVE-2026-34400 · NVD
- FIRST EPSS
- GHSA-8prr-286p-4w7j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences